Bug 995089 - GIO support shouldn't check GTK2 version if GTK3 build. r=glandium
authorMakoto Kato <m_kato@ga2.so-net.ne.jp>
Fri, 18 Apr 2014 13:20:04 +0900
changeset 179613 979545ea8f9ea724439a39bcd73cc31ca92f00ef
parent 179612 1c436dd6020fca6c63cf4db6e0e24a28139d6ff4
child 179614 24496a6b3fea8da928b1106009bf8012072508cd
push id272
push userpvanderbeken@mozilla.com
push dateMon, 05 May 2014 16:31:18 +0000
reviewersglandium
bugs995089
milestone31.0a1
Bug 995089 - GIO support shouldn't check GTK2 version if GTK3 build. r=glandium
configure.in
--- a/configure.in
+++ b/configure.in
@@ -4816,18 +4816,21 @@ then
     dnl ========================================================
     MOZ_ARG_DISABLE_BOOL(gio,
     [  --disable-gio           Disable GIO support],
         MOZ_ENABLE_GIO=,
         MOZ_ENABLE_GIO=force)
 
     if test "$MOZ_ENABLE_GIO" -a "$MOZ_ENABLE_GTK"
     then
-        PKG_CHECK_MODULES(_GTKCHECK, gtk+-2.0 >= 2.14, ,
-                          [AC_MSG_ERROR([* * * Could not find gtk+-2.0 > 2.14. Required for build with gio.])])
+        if test "$MOZ_ENABLE_GTK2"
+        then
+            PKG_CHECK_MODULES(_GTKCHECK, gtk+-2.0 >= 2.14, ,
+                              [AC_MSG_ERROR([* * * Could not find gtk+-2.0 > 2.14. Required for build with gio.])])
+        fi
         PKG_CHECK_MODULES(MOZ_GIO, gio-2.0 >= $GIO_VERSION,[
             MOZ_GIO_LIBS=`echo $MOZ_GIO_LIBS | sed 's/-llinc\>//'`
             MOZ_ENABLE_GIO=1
             AC_DEFINE(MOZ_ENABLE_GIO)
         ],[
             if test "$MOZ_ENABLE_GIO" = "force"
             then
                 AC_MSG_ERROR([* * * Could not find gio-2.0 >= $GIO_VERSION])