Bug 1417309 - Only build elfhack when building a toolkit-based application. r=nalexander
authorMike Hommey <mh+mozilla@glandium.org>
Wed, 08 Nov 2017 09:10:18 +0900
changeset 436593 8c4fac311fe1fa7ffa906a87333e949de542e317
parent 436592 696538512fd9d37623d7ff3ed6c311d86266671e
child 436594 74a6998f7206ed69b56b290a5eed70f187eb50ac
push id117
push userfmarier@mozilla.com
push dateTue, 28 Nov 2017 20:17:16 +0000
reviewersnalexander
bugs1417309
milestone59.0a1
Bug 1417309 - Only build elfhack when building a toolkit-based application. r=nalexander
old-configure.in
--- a/old-configure.in
+++ b/old-configure.in
@@ -3888,17 +3888,19 @@ MOZ_ARG_ENABLE_BOOL(install-strip,
 [  --enable-install-strip  Enable stripping of libs & executables when packaging ],
     PKG_SKIP_STRIP= ,
     PKG_SKIP_STRIP=1)
 
 dnl ========================================================
 dnl = --disable-elf-hack
 dnl ========================================================
 
-USE_ELF_HACK=1
+if test -n "$MOZ_WIDGET_TOOLKIT"; then
+    USE_ELF_HACK=1
+fi
 MOZ_ARG_DISABLE_BOOL(elf-hack,
 [  --disable-elf-hack      Disable elf hacks],
     [USE_ELF_HACK=],
     [USE_ELF_HACK=1])
 
 # Only enable elfhack where supported
 if test "$USE_ELF_HACK" = 1; then
     case "${HOST_OS_ARCH},${OS_ARCH}" in