bug 1356240 - enable reftest-gpu-e10s on taskcluster win tier 3; try: -b do -p win32,win64 -u reftest-gpu -t none
authorRob Thijssen <rthijssen@mozilla.com>
Wed, 31 May 2017 12:24:15 +0300
changeset 1142643 1a84ae607b5674037c4f63f019620bac88d2ed43
parent 1142443 925230851743b9a969a3142f00aea5014a33cb02
child 1238284 39b1e22c60a6b966f279e56265d3e7a32a96033c
push id194129
push userrthijssen@mozilla.com
push dateWed, 31 May 2017 09:24:56 +0000
treeherdertry@1a84ae607b56 [default view] [failures only]
bugs1356240
milestone55.0a1
bug 1356240 - enable reftest-gpu-e10s on taskcluster win tier 3; try: -b do -p win32,win64 -u reftest-gpu -t none
taskcluster/ci/test/test-sets.yml
taskcluster/ci/test/tests.yml
--- a/taskcluster/ci/test/test-sets.yml
+++ b/taskcluster/ci/test/test-sets.yml
@@ -150,16 +150,17 @@ windows-vm-tests:
     - mochitest-jetpack
     - mochitest-media
     - web-platform-tests
     - web-platform-tests-reftests
     #- xpcshell
 
 windows-gpu-tests:
     - reftest
+    - reftest-gpu
     - reftest-no-accel
     - mochitest-gpu
     - mochitest-webgl
 
 # these tests currently run on hardware, but may migrate above when validated
 # see https://bugzilla.mozilla.org/show_bug.cgi?id=1280474#c36
 #    - mochitest-chrome
 #    - mochitest-clipboard
--- a/taskcluster/ci/test/tests.yml
+++ b/taskcluster/ci/test/tests.yml
@@ -1118,16 +1118,41 @@ reftest:
                             - remove_executables.py
                 extra-options:
                     - --reftest-suite=reftest
     tier:
         by-test-platform:
             linux64-qr/.*: 1
             default: default
 
+reftest-gpu:
+    description: "someone who knows what this test does, should write something here"
+    suite: reftest/reftest-gpu
+    treeherder-symbol: tc-R(Rg)
+    run-on-projects:
+        by-test-platform:
+            linux.*: []
+            macosx.*: []
+            windows.*: ['mozilla-central', 'try']
+            default: built-projects
+    e10s: true
+    mozharness:
+        script: desktop_unittest.py
+        no-read-buildbot-config: true
+        config:
+            by-test-platform:
+                windows.*:
+                    - unittests/win_taskcluster_unittest.py
+        extra-options:
+            - --reftest-suite=reftest-gpu
+    tier:
+        by-test-platform:
+            windows.*: 3
+            default: default
+
 reftest-no-accel:
     description: "Reftest not accelerated run"
     suite: reftest/reftest-no-accel
     treeherder-symbol: tc-R(Ru)
     docker-image: {"in-tree": "desktop1604-test"}
     run-on-projects:
         by-test-platform:
             windows10.*: []