Bug 1424798 - remove deny(warnings) from style/lib.rs to fix bustage. r=bustage-fix a=bustage-fix
authorSebastian Hengst <archaeopteryx@coole-files.de>
Thu, 21 Dec 2017 14:51:50 +0200
changeset 445426 beebff82806748d5506edc22d9ce4f15f81525cb
parent 445425 8240bb64efb787014749a46d3a8e3781242be89e
child 445427 f5855487cb440f636aab4816837cd6fb6bac3c1b
push id1618
push userCallek@gmail.com
push dateThu, 11 Jan 2018 17:45:48 +0000
treeherdermozilla-release@882ca853e05a [default view] [failures only]
perfherder[talos] [build metrics] [platform microbench] (compared to previous push)
reviewersbustage-fix, bustage-fix
bugs1424798
milestone58.0
Bug 1424798 - remove deny(warnings) from style/lib.rs to fix bustage. r=bustage-fix a=bustage-fix
servo/components/style/lib.rs
--- a/servo/components/style/lib.rs
+++ b/servo/components/style/lib.rs
@@ -18,17 +18,16 @@
 //! [recalc_style_at]: traversal/fn.recalc_style_at.html
 //!
 //! Major dependencies are the [cssparser][cssparser] and [selectors][selectors]
 //! crates.
 //!
 //! [cssparser]: ../cssparser/index.html
 //! [selectors]: ../selectors/index.html
 
-#![deny(warnings)]
 #![deny(missing_docs)]
 
 // FIXME(bholley): We need to blanket-allow unsafe code in order to make the
 // gecko atom!() macro work. When Rust 1.14 is released [1], we can uncomment
 // the commented-out attributes in regen_atoms.py and go back to denying unsafe
 // code by default.
 //
 // [1] https://github.com/rust-lang/rust/issues/15701#issuecomment-251900615