Bug 1560545 - Change libdrm version check in configure. r=chmanchester
authorMike Hommey <mh+mozilla@glandium.org>
Wed, 26 Jun 2019 05:02:42 +0000
changeset 542972 b20b355373b444b5a9a303777631f99141149a2b
parent 542971 a961572fed142f07043653cce2a86f6955db6f68
child 542973 34448603afab85cff56deb3c8ccff9c34703d2a6
child 542979 0b8f1947271e2efed2ed9e84e0ff20cac3606977
child 543018 3ea8a293b2d1a3ad00abf170116f87ef101a975d
push id2131
push userffxbld-merge
push dateMon, 26 Aug 2019 18:30:20 +0000
treeherdermozilla-release@b19ffb3ca153 [default view] [failures only]
perfherder[talos] [build metrics] [platform microbench] (compared to previous push)
reviewerschmanchester
bugs1560545
milestone69.0a1
first release with
nightly linux32
b20b355373b4 / 69.0a1 / 20190626093633 / files
nightly linux64
b20b355373b4 / 69.0a1 / 20190626093633 / files
nightly mac
b20b355373b4 / 69.0a1 / 20190626093633 / files
nightly win32
b20b355373b4 / 69.0a1 / 20190626093633 / files
nightly win64
b20b355373b4 / 69.0a1 / 20190626093633 / files
last release without
nightly linux32
nightly linux64
nightly mac
nightly win32
nightly win64
releases
nightly linux32
nightly linux64
nightly mac
nightly win32
nightly win64
Bug 1560545 - Change libdrm version check in configure. r=chmanchester Differential Revision: https://phabricator.services.mozilla.com/D35753
toolkit/moz.configure
--- a/toolkit/moz.configure
+++ b/toolkit/moz.configure
@@ -245,17 +245,17 @@ def toolkit_gtk(toolkit):
 
 set_config('MOZ_X11', True, when=toolkit_gtk)
 set_define('MOZ_X11', True, when=toolkit_gtk)
 add_old_configure_assignment('MOZ_X11', True, when=toolkit_gtk)
 
 # Wayland support
 # ==============================================================
 wayland_headers = pkg_check_modules(
-    'MOZ_WAYLAND', 'gtk+-wayland-3.0 >= 3.10 xkbcommon >= 0.4.1 libdrm > 2.4',
+    'MOZ_WAYLAND', 'gtk+-wayland-3.0 >= 3.10 xkbcommon >= 0.4.1 libdrm >= 2.4',
     allow_missing=depends(full_toolkit)(lambda t: t == 'cairo-gtk3'),
     when=depends(full_toolkit)(lambda t: t in ('cairo-gtk3', 'cairo-gtk3-wayland')))
 
 
 @depends(wayland_headers, toolkit_gtk, artifact_builds)
 def wayland_headers(wayland, toolkit_gtk, artifacts):
     if toolkit_gtk and artifacts:
         return True