Bug 421689: Mozilla won't build with XCode 3.1/more stable fix; r=ted.mielczarek, a1.9+=damons
authormnyromyr@tprac.de
Thu, 13 Mar 2008 14:18:32 -0700
changeset 13032 80caf2db38037e8261fb4633d25c1414b3a94c13
parent 13031 a995c4943527e68caad2aceded1fc954966f2889
child 13033 d89530bf9f74efe26984b9e97c36fc2fe05557e0
push idunknown
push userunknown
push dateunknown
reviewersted
bugs421689
milestone1.9b5pre
Bug 421689: Mozilla won't build with XCode 3.1/more stable fix; r=ted.mielczarek, a1.9+=damons
configure.in
--- a/configure.in
+++ b/configure.in
@@ -702,17 +702,17 @@ from building Mozilla. Upgrade to Xcode 
     dnl xcodebuild needs GCC_VERSION defined in the environment, since it
     dnl doesn't respect the CC/CXX setting.  With GCC_VERSION set, it will use
     dnl /usr/bin/g(cc|++)-$GCC_VERSION.
     AC_PATH_PROGS(PBBUILD, pbbuild xcodebuild pbxbuild)
 
     case "$PBBUILD" in
       *xcodebuild*)
         changequote(,)
-        XCODEBUILD_VERSION=`$PBBUILD -version 2>/dev/null | sed -e 's/.*DevToolsCore-\([0-9]*\).*/\1/' | tail -n 1`
+        XCODEBUILD_VERSION=`$PBBUILD -version 2>/dev/null | xargs | sed -e 's/.*DevToolsCore-\([0-9]*\).*/\1/'`
         changequote([,])
         if test -n "$XCODEBUILD_VERSION" && test "$XCODEBUILD_VERSION" -ge 620 ; then
           HAS_XCODE_2_1=1;
         fi
       ;;
     esac
 
     dnl sdp was formerly in /Developer/Tools.  As of Mac OS X 10.4 (Darwin 8),