Bug 1257870 - Require 1.5.0 --with-system-libvpx. r=glandium, a=ritu
authorRalph Giles <giles@mozilla.com>
Mon, 28 Mar 2016 16:35:00 +0200
changeset 325651 49baa8de350f45216d7e2b4bb0509ac6c16ae9cd
parent 325650 a9534031e9d241cd7a78a0f652b9659eb6d87839
child 325652 26411f370dad912d93f8d145b3ec832aff38af21
push id1128
push userjlund@mozilla.com
push dateWed, 01 Jun 2016 01:31:59 +0000
treeherdermozilla-release@fe0d30de989d [default view] [failures only]
perfherder[talos] [build metrics] [platform microbench] (compared to previous push)
reviewersglandium, ritu
bugs1257870, 1237023, 1248335
Bug 1257870 - Require 1.5.0 --with-system-libvpx. r=glandium, a=ritu WebRTC code requires VP9E_SET_NOISE_SENSITIVITY from vpx/vp8cx.h which was added in 1.4. We could feature test, but gating on the minimum version seems better given the m4 code is to be replaced by python. We also depend on VPX_MAX_LAYERS wich is part of the 1.5.0 release. This dependency was added with an SVC support patch in May 2015, bug 1237023. Optional --enable-spatial-svc is handled by the work-around in bug 1248335. MozReview-Commit-ID: 79kg9JSFtJM
--- a/old-configure.in
+++ b/old-configure.in
@@ -5326,17 +5326,17 @@ fi
 if test -n "$MOZ_NATIVE_LIBVPX"; then
     dnl ============================
     dnl === libvpx Version check ===
     dnl ============================
     dnl Check to see if we have a system libvpx package.
-    PKG_CHECK_MODULES(MOZ_LIBVPX, vpx >= 1.3.0)
+    PKG_CHECK_MODULES(MOZ_LIBVPX, vpx >= 1.5.0)
     MOZ_CHECK_HEADER([vpx/vpx_decoder.h], [],
      [AC_MSG_ERROR([Couldn't find vpx/vpx_decoder.h which is required for build with system libvpx. Use --without-system-libvpx to build with in-tree libvpx.])])
     AC_CHECK_LIB(vpx, vpx_codec_dec_init_ver, [],