Bug 1523611 - Require libvpx >= 1.7.0. r=dminor a=lizzard
authorPaul Adenot <paul@paul.cx>
Wed, 30 Jan 2019 15:55:10 +0000
changeset 515648 34bde0c12172e514a8062c3aa83af6ba6ed94115
parent 515647 dc3e444e4a2ced7aeee4164899ef93c78582381e
child 515649 5d3f8d82bf37e8faf90da579dec2667dfd4af74d
push id1953
push userffxbld-merge
push dateMon, 11 Mar 2019 12:10:20 +0000
treeherdermozilla-release@9c35dcbaa899 [default view] [failures only]
perfherder[talos] [build metrics] [platform microbench] (compared to previous push)
reviewersdminor, lizzard
bugs1523611
milestone66.0
Bug 1523611 - Require libvpx >= 1.7.0. r=dminor a=lizzard Differential Revision: https://phabricator.services.mozilla.com/D18085
toolkit/moz.configure
--- a/toolkit/moz.configure
+++ b/toolkit/moz.configure
@@ -1336,17 +1336,17 @@ with only_when(compile_environment):
 # VPX
 # ===
 
 with only_when(compile_environment):
     option('--with-system-libvpx',
            help='Use system libvpx (located with pkgconfig)')
 
     with only_when('--with-system-libvpx'):
-        vpx = pkg_check_modules('MOZ_LIBVPX', 'vpx >= 1.5.0')
+        vpx = pkg_check_modules('MOZ_LIBVPX', 'vpx >= 1.7.0')
 
         check_header('vpx/vpx_decoder.h', flags=vpx.cflags, onerror=lambda: die(
             "Couldn't find vpx/vpx_decoder.h, which is required to build "
             "with system libvpx. Use --without-system-libvpx to build "
             "with in-tree libvpx."))
 
         check_symbol('vpx_codec_dec_init_ver', flags=vpx.libs, onerror=lambda: die(
             "--with-system-libvpx requested but symbol vpx_codec_dec_init_ver "