Bug 1534702 - Release marionette_driver 3.0.0 and marionette_harness 5.0.0. r=webdriver-reviewers,ato a=test-only
authorHenrik Skupin <mail@hskupin.info>
Thu, 10 Oct 2019 15:43:58 +0000
changeset 555628 3066a0bce93e2b38da82d6dcf664436d26f4816c
parent 555627 72c1a2621cb65050fbc00adc391c00199f82c94d
child 555629 21e7195d908e17ee21123048e775b84ac1d5f1a1
push id2165
push userffxbld-merge
push dateMon, 14 Oct 2019 16:30:58 +0000
treeherdermozilla-release@0eae18af659f [default view] [failures only]
perfherder[talos] [build metrics] [platform microbench] (compared to previous push)
reviewerswebdriver-reviewers, ato, test-only
bugs1534702
milestone70.0
Bug 1534702 - Release marionette_driver 3.0.0 and marionette_harness 5.0.0. r=webdriver-reviewers,ato a=test-only This will be the last public release of both packages on PyPI. See the announcement from January this year: https://groups.google.com/forum/#!topic/mozilla.tools.marionette/s6_03Qt2ubc If both packages are still required by tools, they would have to be self-built by a checkout of mozilla-central. Differential Revision: https://phabricator.services.mozilla.com/D48674
testing/marionette/client/marionette_driver/__init__.py
testing/marionette/harness/marionette_harness/__init__.py
testing/marionette/harness/requirements.txt
--- a/testing/marionette/client/marionette_driver/__init__.py
+++ b/testing/marionette/client/marionette_driver/__init__.py
@@ -1,15 +1,15 @@
 # This Source Code Form is subject to the terms of the Mozilla Public
 # License, v. 2.0. If a copy of the MPL was not distributed with this
 # file, You can obtain one at http://mozilla.org/MPL/2.0/.
 
 from __future__ import absolute_import
 
-__version__ = '2.8.0'
+__version__ = '3.0.0'
 
 from marionette_driver import (
     addons,
     by,
     date_time_value,
     decorators,
     errors,
     expected,
--- a/testing/marionette/harness/marionette_harness/__init__.py
+++ b/testing/marionette/harness/marionette_harness/__init__.py
@@ -1,15 +1,15 @@
 # This Source Code Form is subject to the terms of the Mozilla Public
 # License, v. 2.0. If a copy of the MPL was not distributed with this
 # file, You can obtain one at http://mozilla.org/MPL/2.0/.
 
 from __future__ import absolute_import
 
-__version__ = '4.6.0'
+__version__ = '5.0.0'
 
 from .marionette_test import (
     CommonTestCase,
     expectedFailure,
     MarionetteTestCase,
     parameterized,
     run_if_e10s,
     run_if_manage_instance,
--- a/testing/marionette/harness/requirements.txt
+++ b/testing/marionette/harness/requirements.txt
@@ -1,11 +1,11 @@
 browsermob-proxy >= 0.8.0
 manifestparser >= 1.1
-marionette-driver >= 2.8.0
+marionette-driver >= 3.0.0
 mozcrash >= 1.1.0
 mozdevice >= 3.0.1
 mozinfo >= 1.0.0
 mozlog >= 4.0
 moznetwork >= 0.27
 mozprocess >= 1.0.0
 mozprofile >= 2.2.0
 mozrunner >= 7.4.0