Bug 1545810 - disable tests in testing/web-platform/meta/media-source/ on windows10-aarch64 that cause task to abort r=jmaher
authorEdwin Gao <egao@mozilla.com>
Sat, 27 Apr 2019 02:09:21 +0000
changeset 533573 2ce05675c4470e08e9cc9dbdecac62518a7df578
parent 533572 28e4375e491e67da9d5238e55a5cf10c5be1eba6
child 533574 fd9f15fe0ec120717b9690ace0b1a42bb01f48a9
push id2082
push userffxbld-merge
push dateMon, 01 Jul 2019 08:34:18 +0000
treeherdermozilla-release@2fb19d0466d2 [default view] [failures only]
perfherder[talos] [build metrics] [platform microbench] (compared to previous push)
reviewersjmaher
bugs1545810
milestone68.0a1
first release with
nightly linux32
nightly linux64
nightly mac
nightly win32
nightly win64
last release without
nightly linux32
nightly linux64
nightly mac
nightly win32
nightly win64
Bug 1545810 - disable tests in testing/web-platform/meta/media-source/ on windows10-aarch64 that cause task to abort r=jmaher Changes: - disable wholesale the `media-source` subsuite within web-platform-test Attempts were made to isolate the tests that cause the test harness to lock up with a permission issue on `Ahem.ttf` however the attempts were unsuccessful in isolating the tests to a manageable set. It appears the solution is to simply stop running `media-source` tests on windows10-aarch64 as that seems to have solved the problem in a previous try run. Differential Revision: https://phabricator.services.mozilla.com/D28778
taskcluster/ci/test/test-sets.yml
testing/web-platform/meta/media-source/__dir__.ini
--- a/taskcluster/ci/test/test-sets.yml
+++ b/taskcluster/ci/test/test-sets.yml
@@ -265,17 +265,17 @@ windows-aarch64-tests:
     - mochitest-devtools-chrome
     - mochitest-gpu
     - mochitest-media
     - mochitest-webgl1-core
     - mochitest-webgl1-ext
     - mochitest-webgl2-core
     - mochitest-webgl2-ext
     - reftest
-    # - web-platform-tests - disabled due to wpt11 experiencing BSoD
+    - web-platform-tests
     - web-platform-tests-reftests
     - xpcshell
 
 windows-talos:
     - talos-bcv
     - talos-chrome
     - talos-damp
     - talos-dromaeojs
--- a/testing/web-platform/meta/media-source/__dir__.ini
+++ b/testing/web-platform/meta/media-source/__dir__.ini
@@ -1,2 +1,4 @@
 prefs: [media.mediasource.experimental.enabled:true]
 leak-threshold: [default: 51200]
+disabled:
+    if (os == "win") and (processor == "aarch64"): https://bugzilla.mozilla.org/show_bug.cgi?id=1545810
\ No newline at end of file