Bug 1413599 - Update the 'switch to ESR' prompt minimum version check to include JAWS versions 18 and lower. r=davidb
authorJim Mathies <jmathies@mozilla.com>
Fri, 03 Nov 2017 12:12:05 -0500
changeset 443349 24f4d2216af90f509e8e490f811031d8fe52653a
parent 443348 d2d9c80e36843979a5c03211dc90f1a5b3e28455
child 443350 899a407832c09e685748779d288637a24aaae2af
push id1618
push userCallek@gmail.com
push dateThu, 11 Jan 2018 17:45:48 +0000
treeherdermozilla-release@882ca853e05a [default view] [failures only]
perfherder[talos] [build metrics] [platform microbench] (compared to previous push)
reviewersdavidb
bugs1413599
milestone58.0a1
first release with
nightly linux32
nightly linux64
nightly mac
nightly win32
nightly win64
last release without
nightly linux32
nightly linux64
nightly mac
nightly win32
nightly win64
Bug 1413599 - Update the 'switch to ESR' prompt minimum version check to include JAWS versions 18 and lower. r=davidb MozReview-Commit-ID: EuA8pKE2KIe
accessible/windows/msaa/Compatibility.cpp
--- a/accessible/windows/msaa/Compatibility.cpp
+++ b/accessible/windows/msaa/Compatibility.cpp
@@ -163,17 +163,17 @@ uint32_t Compatibility::sConsumers = Com
 
 void
 Compatibility::Init()
 {
   // Note we collect some AT statistics/telemetry here for convenience.
 
   HMODULE jawsHandle = ::GetModuleHandleW(L"jhook");
   if (jawsHandle)
-    sConsumers |= (IsModuleVersionLessThan(jawsHandle, 18, 4315)) ?
+    sConsumers |= (IsModuleVersionLessThan(jawsHandle, 19, 0)) ?
                    OLDJAWS : JAWS;
 
   if (::GetModuleHandleW(L"gwm32inc"))
     sConsumers |= WE;
 
   if (::GetModuleHandleW(L"dolwinhk"))
     sConsumers |= DOLPHIN;