Bug 1557123 - migrate web-platform-tests and web-platform-test-reftests to osx 10.14. r=egao a=test-only
☠☠ backed out by 03e5d1efd942 ☠ ☠
authorJoel Maher <jmaher@mozilla.com>
Tue, 25 Jun 2019 13:55:07 -0400
changeset 537140 071ec1758f2f88b1af3c937e3e387fa2ccf937db
parent 537139 8e2ab52b6eb7c57a8d28fd6d679b0e863a83e989
child 537141 bdab153eb4e544bb14c81edcf3537bf26fe5ec91
push id2082
push userffxbld-merge
push dateMon, 01 Jul 2019 08:34:18 +0000
treeherdermozilla-release@2fb19d0466d2 [default view] [failures only]
perfherder[talos] [build metrics] [platform microbench] (compared to previous push)
reviewersegao, test-only
bugs1557123
milestone68.0
Bug 1557123 - migrate web-platform-tests and web-platform-test-reftests to osx 10.14. r=egao a=test-only
taskcluster/ci/test/test-sets.yml
testing/web-platform/meta/css/css-values/ch-unit-001.html.ini
testing/web-platform/meta/css/css-values/ch-unit-003.html.ini
testing/web-platform/meta/css/css-values/ch-unit-004.html.ini
testing/web-platform/meta/html/semantics/embedded-content/media-elements/track/track-element/track-mode.html.ini
testing/web-platform/meta/html/semantics/embedded-content/the-iframe-element/iframe_sandbox_navigation_download_block_downloads_without_user_activation.sub.tentative.html.ini
testing/web-platform/meta/webaudio/the-audio-api/the-mediaelementaudiosourcenode-interface/mediaElementAudioSourceToScriptProcessorTest.html.ini
testing/web-platform/meta/xhr/event-timeout.any.js.ini
--- a/taskcluster/ci/test/test-sets.yml
+++ b/taskcluster/ci/test/test-sets.yml
@@ -305,42 +305,42 @@ marionette-gpu-tests:
     - marionette-gpu
 
 marionette-media-tests:
     - marionette-media
 
 # macosx1014-64-tests:
 #    - cppunit
 #    - crashtest
-#    - firefox-ui-functional-local
-#    - firefox-ui-functional-remote
+    # - firefox-ui-functional-local
+    # - firefox-ui-functional-remote
 #    - gtest
 #    - jittest
 #    - jsreftest
-#    - marionette
+    # - marionette
 #    - mochitest
-#    - mochitest-a11y
+    # - mochitest-a11y
 #    - mochitest-browser-chrome
 #    - mochitest-chrome
 #    - mochitest-devtools-chrome
 #    - mochitest-devtools-webreplay
 #    - mochitest-gpu
 #    - mochitest-media
 #    - mochitest-webgl1-core
 #    - mochitest-webgl1-ext
 #    - mochitest-webgl2-core
 #     - mochitest-webgl2-ext test  # timeouts
-#    - reftest
+    # - reftest
 #    - telemetry-tests-client
-#    - test-verify
-#    - test-verify-gpu
-#    - test-verify-wpt
-#    - web-platform-tests
-#    - web-platform-tests-reftests
-#    - web-platform-tests-wdspec
+    # - test-verify
+    # - test-verify-gpu
+    # - test-verify-wpt
+    - web-platform-tests
+    - web-platform-tests-reftests
+    # - web-platform-tests-wdspec
 #    - xpcshell
 
 # macosx1014-64-qr-tests:
 #    - crashtest
 #    - reftest
 
 macosx64-tests:
     - cppunit
@@ -363,18 +363,16 @@ macosx64-tests:
     - mochitest-webgl1-ext
     - mochitest-webgl2-core
     # - mochitest-webgl2-ext test timeouts
     - reftest
     - telemetry-tests-client
     - test-verify
     - test-verify-gpu
     - test-verify-wpt
-    - web-platform-tests
-    - web-platform-tests-reftests
     - web-platform-tests-wdspec
     - xpcshell
 
 macosx64-talos:
     - talos-bcv
     - talos-chrome
     - talos-damp
     - talos-dromaeojs
deleted file mode 100644
--- a/testing/web-platform/meta/css/css-values/ch-unit-001.html.ini
+++ /dev/null
@@ -1,3 +0,0 @@
-[ch-unit-001.html]
-  expected:
-    if os == "mac": FAIL
deleted file mode 100644
--- a/testing/web-platform/meta/css/css-values/ch-unit-003.html.ini
+++ /dev/null
@@ -1,3 +0,0 @@
-[ch-unit-003.html]
-  expected:
-    if (os == "mac"): FAIL
deleted file mode 100644
--- a/testing/web-platform/meta/css/css-values/ch-unit-004.html.ini
+++ /dev/null
@@ -1,3 +0,0 @@
-[ch-unit-004.html]
-  expected:
-    if os == "mac": FAIL
new file mode 100644
--- /dev/null
+++ b/testing/web-platform/meta/html/semantics/embedded-content/media-elements/track/track-element/track-mode.html.ini
@@ -0,0 +1,3 @@
+[track-mode.html]
+  disabled:
+    if (os == "mac") and (version == "OS X 10.14"): new platform
--- a/testing/web-platform/meta/html/semantics/embedded-content/the-iframe-element/iframe_sandbox_navigation_download_block_downloads_without_user_activation.sub.tentative.html.ini
+++ b/testing/web-platform/meta/html/semantics/embedded-content/the-iframe-element/iframe_sandbox_navigation_download_block_downloads_without_user_activation.sub.tentative.html.ini
@@ -1,4 +1,6 @@
 [iframe_sandbox_navigation_download_block_downloads_without_user_activation.sub.tentative.html]
   [Navigation resulted download in sandbox is blocked.]
+    disabled:
+        if (os == "mac") and (version == "OS X 10.14") and not debug: new os version
     expected: FAIL
 
new file mode 100644
--- /dev/null
+++ b/testing/web-platform/meta/webaudio/the-audio-api/the-mediaelementaudiosourcenode-interface/mediaElementAudioSourceToScriptProcessorTest.html.ini
@@ -0,0 +1,4 @@
+[mediaElementAudioSourceToScriptProcessorTest.html]
+  disbled:
+    if (os == "mac") and (version == "OS X 10.14"): new platform
+
new file mode 100644
--- /dev/null
+++ b/testing/web-platform/meta/xhr/event-timeout.any.js.ini
@@ -0,0 +1,3 @@
+[event-timeout.any.worker.html]
+  disabled:
+    if (os == "mac") and (version == "OS X 10.14"): https://bugzilla.mozilla.org/show_bug.cgi?id=1557123
\ No newline at end of file