Bug 1546662 - Disable webauthn tests for instability, a=testonly
authorJames Graham <james@hoppipolla.co.uk>
Wed, 24 Apr 2019 14:49:30 +0100
changeset 529988 da523e237c3d922401d8d3e53fdabe14621d7eac
parent 529987 55de487e32e6c6b01f1e37ee96f23a63e5c8b638
child 529989 cfafd091d30107f974a22c06ef790bee7950c1cd
push id11265
push userffxbld-merge
push dateMon, 13 May 2019 10:53:39 +0000
treeherdermozilla-beta@77e0fe8dbdd3 [default view] [failures only]
perfherder[talos] [build metrics] [platform microbench] (compared to previous push)
reviewerstestonly
bugs1546662
milestone68.0a1
first release with
nightly linux32
nightly linux64
nightly mac
nightly win32
nightly win64
last release without
nightly linux32
nightly linux64
nightly mac
nightly win32
nightly win64
Bug 1546662 - Disable webauthn tests for instability, a=testonly
testing/web-platform/meta/webauthn/createcredential-badargs-authnrselection.https.html.ini
testing/web-platform/meta/webauthn/createcredential-badargs-rp.https.html.ini
testing/web-platform/meta/webauthn/createcredential-badargs-user.https.html.ini
testing/web-platform/meta/webauthn/createcredential-excludecredentials.https.html.ini
testing/web-platform/meta/webauthn/createcredential-extensions.https.html.ini
testing/web-platform/meta/webauthn/createcredential-passing.https.html.ini
testing/web-platform/meta/webauthn/getcredential-badargs-rpid.https.html.ini
testing/web-platform/meta/webauthn/getcredential-badargs-userverification.https.html.ini
testing/web-platform/meta/webauthn/getcredential-extensions.https.html.ini
testing/web-platform/meta/webauthn/getcredential-passing.https.html.ini
testing/web-platform/meta/webauthn/getcredential-timeout.https.html.ini
--- a/testing/web-platform/meta/webauthn/createcredential-badargs-authnrselection.https.html.ini
+++ b/testing/web-platform/meta/webauthn/createcredential-badargs-authnrselection.https.html.ini
@@ -1,9 +1,10 @@
 [createcredential-badargs-authnrselection.https.html]
+  disabled: https://bugzilla.mozilla.org/show_bug.cgi?id=1546662
   expected:
     if os == "android" and not e10s: OK
     TIMEOUT
   [Bad AuthenticatorSelectionCriteria: authenticatorSelection is empty array]
     expected:
       if os == "android" and not e10s: FAIL
       if debug and not webrender and e10s and (os == "linux") and (version == "Ubuntu 16.04") and (processor == "x86") and (bits == 32): FAIL
       if debug and not webrender and not e10s and (os == "linux") and (version == "Ubuntu 16.04") and (processor == "x86") and (bits == 32): FAIL
--- a/testing/web-platform/meta/webauthn/createcredential-badargs-rp.https.html.ini
+++ b/testing/web-platform/meta/webauthn/createcredential-badargs-rp.https.html.ini
@@ -1,9 +1,10 @@
 [createcredential-badargs-rp.https.html]
+  disabled: https://bugzilla.mozilla.org/show_bug.cgi?id=1546662
   expected:
     if os == "android" and not e10s: OK
     TIMEOUT
   [Bad rp: id is object]
     expected: FAIL
 
   [Bad rp: name is object]
     expected:
--- a/testing/web-platform/meta/webauthn/createcredential-badargs-user.https.html.ini
+++ b/testing/web-platform/meta/webauthn/createcredential-badargs-user.https.html.ini
@@ -1,9 +1,10 @@
 [createcredential-badargs-user.https.html]
+  disabled: https://bugzilla.mozilla.org/show_bug.cgi?id=1546662
   expected:
     if os == "android" and not e10s: OK
     TIMEOUT
   [Bad user: id is empty ArrayBuffer]
     expected:
       if os == "android" and not e10s: FAIL
       if debug and webrender and e10s and (os == "linux") and (version == "Ubuntu 16.04") and (processor == "x86_64") and (bits == 64): FAIL
       if debug and webrender and e10s and (os == "win") and (version == "10.0.17134") and (processor == "x86_64") and (bits == 64): FAIL
--- a/testing/web-platform/meta/webauthn/createcredential-excludecredentials.https.html.ini
+++ b/testing/web-platform/meta/webauthn/createcredential-excludecredentials.https.html.ini
@@ -1,9 +1,10 @@
 [createcredential-excludecredentials.https.html]
+  disabled: https://bugzilla.mozilla.org/show_bug.cgi?id=1546662
   expected:
     if os == "android" and not e10s: OK
     TIMEOUT
   [excludeCredentials missing]
     expected:
       if os == "android" and not e10s: FAIL
       if debug and not webrender and e10s and (os == "linux") and (version == "Ubuntu 16.04") and (processor == "x86") and (bits == 32): FAIL
       if debug and not webrender and not e10s and (os == "linux") and (version == "Ubuntu 16.04") and (processor == "x86") and (bits == 32): FAIL
--- a/testing/web-platform/meta/webauthn/createcredential-extensions.https.html.ini
+++ b/testing/web-platform/meta/webauthn/createcredential-extensions.https.html.ini
@@ -1,9 +1,10 @@
 [createcredential-extensions.https.html]
+  disabled: https://bugzilla.mozilla.org/show_bug.cgi?id=1546662
   expected:
     if os == "android" and not e10s: OK
     TIMEOUT
   [Bad extensions: extensions is null]
     expected:
       if os == "android" and not e10s: FAIL
       if debug and not webrender and e10s and (os == "linux") and (version == "Ubuntu 16.04") and (processor == "x86") and (bits == 32): FAIL
       if debug and not webrender and not e10s and (os == "linux") and (version == "Ubuntu 16.04") and (processor == "x86") and (bits == 32): FAIL
--- a/testing/web-platform/meta/webauthn/createcredential-passing.https.html.ini
+++ b/testing/web-platform/meta/webauthn/createcredential-passing.https.html.ini
@@ -1,9 +1,10 @@
 [createcredential-passing.https.html]
+  disabled: https://bugzilla.mozilla.org/show_bug.cgi?id=1546662
   expected: TIMEOUT
   [WebAuthn credential.create() Passing Tests]
     expected: TIMEOUT
 
   [passing credentials.create() with default arguments]
     expected:
       if os == "android" and not e10s: FAIL
       if debug and not webrender and e10s and (os == "linux") and (version == "Ubuntu 16.04") and (processor == "x86") and (bits == 32): FAIL
--- a/testing/web-platform/meta/webauthn/getcredential-badargs-rpid.https.html.ini
+++ b/testing/web-platform/meta/webauthn/getcredential-badargs-rpid.https.html.ini
@@ -1,9 +1,10 @@
 [getcredential-badargs-rpid.https.html]
+  disabled: https://bugzilla.mozilla.org/show_bug.cgi?id=1546662
   expected:
     if os == "android" and not e10s: OK
     if debug and not webrender and e10s and (os == "linux") and (version == "Ubuntu 16.04") and (processor == "x86") and (bits == 32): OK
     if debug and not webrender and not e10s and (os == "linux") and (version == "Ubuntu 16.04") and (processor == "x86") and (bits == 32): OK
     if debug and not webrender and e10s and (os == "linux") and (version == "Ubuntu 16.04") and (processor == "x86_64") and (bits == 64): OK
     if debug and not webrender and e10s and (os == "win") and (version == "10.0.17134") and (processor == "x86_64") and (bits == 64): OK
     if debug and webrender and e10s and (os == "win") and (version == "10.0.17134") and (processor == "x86_64") and (bits == 64): OK
     if debug and webrender and e10s and (os == "linux") and (version == "Ubuntu 16.04") and (processor == "x86_64") and (bits == 64): OK
--- a/testing/web-platform/meta/webauthn/getcredential-badargs-userverification.https.html.ini
+++ b/testing/web-platform/meta/webauthn/getcredential-badargs-userverification.https.html.ini
@@ -1,9 +1,10 @@
 [getcredential-badargs-userverification.https.html]
+  disabled: https://bugzilla.mozilla.org/show_bug.cgi?id=1546662
   expected:
     if os == "android" and not e10s: OK
     if debug and not webrender and e10s and (os == "linux") and (version == "Ubuntu 16.04") and (processor == "x86") and (bits == 32): OK
     if debug and not webrender and not e10s and (os == "linux") and (version == "Ubuntu 16.04") and (processor == "x86") and (bits == 32): OK
     if debug and not webrender and e10s and (os == "linux") and (version == "Ubuntu 16.04") and (processor == "x86_64") and (bits == 64): OK
     if debug and not webrender and e10s and (os == "win") and (version == "10.0.17134") and (processor == "x86_64") and (bits == 64): OK
     if debug and webrender and e10s and (os == "win") and (version == "10.0.17134") and (processor == "x86_64") and (bits == 64): OK
     if debug and webrender and e10s and (os == "linux") and (version == "Ubuntu 16.04") and (processor == "x86_64") and (bits == 64): OK
--- a/testing/web-platform/meta/webauthn/getcredential-extensions.https.html.ini
+++ b/testing/web-platform/meta/webauthn/getcredential-extensions.https.html.ini
@@ -1,9 +1,10 @@
 [getcredential-extensions.https.html]
+  disabled: https://bugzilla.mozilla.org/show_bug.cgi?id=1546662
   expected:
     if os == "android" and not e10s: OK
     if debug and not webrender and e10s and (os == "linux") and (version == "Ubuntu 16.04") and (processor == "x86") and (bits == 32): OK
     if debug and not webrender and not e10s and (os == "linux") and (version == "Ubuntu 16.04") and (processor == "x86") and (bits == 32): OK
     if debug and not webrender and e10s and (os == "linux") and (version == "Ubuntu 16.04") and (processor == "x86_64") and (bits == 64): OK
     if debug and not webrender and e10s and (os == "win") and (version == "10.0.17134") and (processor == "x86_64") and (bits == 64): OK
     if debug and webrender and e10s and (os == "win") and (version == "10.0.17134") and (processor == "x86_64") and (bits == 64): OK
     if debug and webrender and e10s and (os == "linux") and (version == "Ubuntu 16.04") and (processor == "x86_64") and (bits == 64): OK
--- a/testing/web-platform/meta/webauthn/getcredential-passing.https.html.ini
+++ b/testing/web-platform/meta/webauthn/getcredential-passing.https.html.ini
@@ -1,9 +1,10 @@
 [getcredential-passing.https.html]
+  disabled: https://bugzilla.mozilla.org/show_bug.cgi?id=1546662
   expected:
     if os == "android" and not e10s: OK
     if debug and not webrender and e10s and (os == "linux") and (version == "Ubuntu 16.04") and (processor == "x86") and (bits == 32): OK
     if debug and not webrender and not e10s and (os == "linux") and (version == "Ubuntu 16.04") and (processor == "x86") and (bits == 32): OK
     if debug and not webrender and e10s and (os == "linux") and (version == "Ubuntu 16.04") and (processor == "x86_64") and (bits == 64): OK
     if debug and not webrender and e10s and (os == "win") and (version == "10.0.17134") and (processor == "x86_64") and (bits == 64): OK
     if debug and webrender and e10s and (os == "win") and (version == "10.0.17134") and (processor == "x86_64") and (bits == 64): OK
     if debug and webrender and e10s and (os == "linux") and (version == "Ubuntu 16.04") and (processor == "x86_64") and (bits == 64): OK
--- a/testing/web-platform/meta/webauthn/getcredential-timeout.https.html.ini
+++ b/testing/web-platform/meta/webauthn/getcredential-timeout.https.html.ini
@@ -1,9 +1,10 @@
 [getcredential-timeout.https.html]
+  disabled: https://bugzilla.mozilla.org/show_bug.cgi?id=1546662
   expected:
     if os == "android" and not e10s: OK
     if debug and not webrender and e10s and (os == "linux") and (version == "Ubuntu 16.04") and (processor == "x86") and (bits == 32): OK
     if debug and not webrender and not e10s and (os == "linux") and (version == "Ubuntu 16.04") and (processor == "x86") and (bits == 32): OK
     if debug and not webrender and e10s and (os == "linux") and (version == "Ubuntu 16.04") and (processor == "x86_64") and (bits == 64): OK
     if debug and not webrender and e10s and (os == "win") and (version == "10.0.17134") and (processor == "x86_64") and (bits == 64): OK
     if debug and webrender and e10s and (os == "win") and (version == "10.0.17134") and (processor == "x86_64") and (bits == 64): OK
     if debug and webrender and e10s and (os == "linux") and (version == "Ubuntu 16.04") and (processor == "x86_64") and (bits == 64): OK