Bug 1395849 - Fix G.722 audio codec; r=jesup
authorDan Minor <dminor@mozilla.com>
Fri, 01 Sep 2017 14:48:36 -0400
changeset 428791 b876f2c2f66305a5d673025eb84eab7cf648a73a
parent 428790 21229f14023fd62a4acaf63ab16b3f12f58e722d
child 428792 2c41ce4850bd7274a65c3e0ab38b2510ff4fa10a
push id7761
push userjlund@mozilla.com
push dateFri, 15 Sep 2017 00:19:52 +0000
treeherdermozilla-beta@c38455951db4 [default view] [failures only]
perfherder[talos] [build metrics] [platform microbench] (compared to previous push)
reviewersjesup
bugs1395849
milestone57.0a1
first release with
nightly linux32
nightly linux64
nightly mac
nightly win32
nightly win64
last release without
nightly linux32
nightly linux64
nightly mac
nightly win32
nightly win64
Bug 1395849 - Fix G.722 audio codec; r=jesup Even though we were building the G.722 codec, we weren't setting the defines so that it would actually be used. MozReview-Commit-ID: Dw8l2sYwZFA
media/webrtc/trunk/webrtc/modules/audio_coding/audio_coding.gypi
--- a/media/webrtc/trunk/webrtc/modules/audio_coding/audio_coding.gypi
+++ b/media/webrtc/trunk/webrtc/modules/audio_coding/audio_coding.gypi
@@ -66,16 +66,20 @@
           ],
           'audio_codec_dependencies': ['g722',],
           'audio_codec_defines': ['WEBRTC_CODEC_G722',],
         }],
         ['build_with_mozilla==0 and build_with_chromium==0', {
           'audio_codec_dependencies': ['red',],
           'audio_codec_defines': ['WEBRTC_CODEC_RED',],
         }],
+        ['build_with_mozilla==1', {
+          'audio_codec_dependencies': ['g722',],
+          'audio_codec_defines': ['WEBRTC_CODEC_G722',],
+        }],
       ],
     },
     'audio_codec_dependencies': '<(audio_codec_dependencies)',
     'audio_codec_defines': '<(audio_codec_defines)',
     'audio_coding_dependencies': [
       '<@(audio_codec_dependencies)',
       '<(webrtc_root)/common.gyp:webrtc_common',
       '<(webrtc_root)/common_audio/common_audio.gyp:common_audio',