Bug 1530794 - [marionette] Bump requirements for Python 3 compatibility. r=ato
☠☠ backed out by a59527dafca1 ☠ ☠
authorHenrik Skupin <mail@hskupin.info>
Tue, 05 Mar 2019 16:27:29 +0000
changeset 520298 b5b2d3cc9e3a55b9057000686c1ad29ce9424748
parent 520297 b28187cd9146f568efa3d4a07a0715594388cda2
child 520299 d03269ca7469f0160cd550537aa6c187890e99ea
push id10862
push userffxbld-merge
push dateMon, 11 Mar 2019 13:01:11 +0000
treeherdermozilla-beta@a2e7f5c935da [default view] [failures only]
perfherder[talos] [build metrics] [platform microbench] (compared to previous push)
reviewersato
bugs1530794
milestone67.0a1
first release with
nightly linux32
nightly linux64
nightly mac
nightly win32
nightly win64
last release without
nightly linux32
nightly linux64
nightly mac
nightly win32
nightly win64
Bug 1530794 - [marionette] Bump requirements for Python 3 compatibility. r=ato Nearly all dependencies except moznetwork and moztest already support Python3. Lets make those releases the minimum allowed version. Differential Revision: https://phabricator.services.mozilla.com/D22105
testing/marionette/client/requirements.txt
testing/marionette/harness/requirements.txt
--- a/testing/marionette/client/requirements.txt
+++ b/testing/marionette/client/requirements.txt
@@ -1,3 +1,3 @@
-mozrunner >= 7.0.1
-mozversion >= 1.1
+mozrunner >= 7.4.0
+mozversion >= 2.1.0
 six
--- a/testing/marionette/harness/requirements.txt
+++ b/testing/marionette/harness/requirements.txt
@@ -1,15 +1,15 @@
-browsermob-proxy >= 0.6.0
+browsermob-proxy >= 0.8.0
 manifestparser >= 1.1
 marionette-driver >= 2.7.0
-mozcrash >= 0.5
-mozdevice >= 1.1.6
-mozinfo >= 0.8
-mozlog >= 3.0
-moznetwork >= 0.21
-mozprocess >= 0.9
-mozprofile >= 0.7
-mozrunner >= 7.0.1
+mozcrash >= 1.1.0
+mozdevice >= 3.0.0
+mozinfo >= 1.0.0
+mozlog >= 4.0
+moznetwork >= 0.27
+mozprocess >= 1.0.0
+mozprofile >= 2.2.0
+mozrunner >= 7.4.0
 moztest >= 0.8
-mozversion >= 1.1
+mozversion >= 2.1.0
 six
 wptserve >= 2.0.0