Bug 1520383 - Default devtools.chrome.enabled to false for inspector markup tests. r=bgrins
authorMatthew Noorenberghe <mozilla@noorenberghe.ca>
Sat, 23 Feb 2019 00:10:48 +0000
changeset 518572 a7b269adadcae3df271ac132c5d6ab6e6dc78b1e
parent 518571 1c9d01a6fbb89c217ba02247f25183f41c6b1952
child 518573 913a5a45b3c51c40db3a086c81bac8b7ea36935b
push id10862
push userffxbld-merge
push dateMon, 11 Mar 2019 13:01:11 +0000
treeherdermozilla-beta@a2e7f5c935da [default view] [failures only]
perfherder[talos] [build metrics] [platform microbench] (compared to previous push)
reviewersbgrins
bugs1520383
milestone67.0a1
first release with
nightly linux32
nightly linux64
nightly mac
nightly win32
nightly win64
last release without
nightly linux32
nightly linux64
nightly mac
nightly win32
nightly win64
Bug 1520383 - Default devtools.chrome.enabled to false for inspector markup tests. r=bgrins This already matches the behaviour for official builds (opt and debug in automation). Tests don't expect event bubbles from chrome event listeners in the inspector on unprivileged test pages. Differential Revision: https://phabricator.services.mozilla.com/D20887
devtools/client/inspector/markup/test/browser.ini
--- a/devtools/client/inspector/markup/test/browser.ini
+++ b/devtools/client/inspector/markup/test/browser.ini
@@ -1,9 +1,14 @@
 [DEFAULT]
+prefs =
+  # Bug 1520383 - Force devtools.chrome.enabled to false regardless of whether
+  # we're in an official build so we don't show event bubbles from chrome event
+  # listeners in the inspector on unprivileged test pages.
+  devtools.chrome.enabled=false
 tags = devtools
 subsuite = devtools
 support-files =
   doc_markup_anonymous.html
   doc_markup_anonymous_xul.xul
   doc_markup_dragdrop.html
   doc_markup_dragdrop_autoscroll_01.html
   doc_markup_dragdrop_autoscroll_02.html