Bug 1188806 - [MSE] Disable tests timing out intermittently. r=karlt, a=test-only
authorJean-Yves Avenard <jyavenard@mozilla.com>
Mon, 24 Aug 2015 10:41:34 +1000
changeset 288874 8d8bbb54965572300061f5bb2224d84daa5479d4
parent 288873 f5e52e74924e0eaf62701e02164cd70bca4e906b
child 288875 b6af21a35119e0eb77e33daed878fd81332201bd
push id5067
push userraliiev@mozilla.com
push dateMon, 21 Sep 2015 14:04:52 +0000
treeherdermozilla-beta@14221ffe5b2f [default view] [failures only]
perfherder[talos] [build metrics] [platform microbench] (compared to previous push)
reviewerskarlt, test-only
bugs1188806
milestone42.0a2
Bug 1188806 - [MSE] Disable tests timing out intermittently. r=karlt, a=test-only MSE with MP4 isn't enabled on linux, so those tests should always be failing.
testing/web-platform/meta/media-source/mediasource-config-change-mp4-av-framesize.html.ini
testing/web-platform/meta/media-source/mediasource-config-change-mp4-av-video-bitrate.html.ini
testing/web-platform/meta/media-source/mediasource-config-change-mp4-v-bitrate.html.ini
testing/web-platform/meta/media-source/mediasource-config-change-mp4-v-framerate.html.ini
testing/web-platform/meta/media-source/mediasource-config-change-mp4-v-framesize.html.ini
--- a/testing/web-platform/meta/media-source/mediasource-config-change-mp4-av-framesize.html.ini
+++ b/testing/web-platform/meta/media-source/mediasource-config-change-mp4-av-framesize.html.ini
@@ -1,8 +1,6 @@
 [mediasource-config-change-mp4-av-framesize.html]
   type: testharness
   prefs: [media.mediasource.enabled:true]
-  [Tests mp4 frame size changes in multiplexed content.]
-    expected:
-      if os == "linux": FAIL
-      if (os == "win") and (version == "5.1.2600"): FAIL
-
+  disabled:
+    if os == "linux": https://bugzilla.mozilla.org/show_bug.cgi?id=1188806
+    if (os == "win") and (version == "5.1.2600"): https://bugzilla.mozilla.org/show_bug.cgi?id=1188806
--- a/testing/web-platform/meta/media-source/mediasource-config-change-mp4-av-video-bitrate.html.ini
+++ b/testing/web-platform/meta/media-source/mediasource-config-change-mp4-av-video-bitrate.html.ini
@@ -1,8 +1,11 @@
 [mediasource-config-change-mp4-av-video-bitrate.html]
   type: testharness
   prefs: [media.mediasource.enabled:true]
+  disabled:
+    if os == "linux": https://bugzilla.mozilla.org/show_bug.cgi?id=1188806
+    if (os == "win") and (version == "5.1.2600"): https://bugzilla.mozilla.org/show_bug.cgi?id=1188806
   [Tests mp4 video bitrate changes in multiplexed content.]
     expected:
       if os == "linux": FAIL
       if (os == "win") and (version == "5.1.2600"): FAIL
 
--- a/testing/web-platform/meta/media-source/mediasource-config-change-mp4-v-bitrate.html.ini
+++ b/testing/web-platform/meta/media-source/mediasource-config-change-mp4-v-bitrate.html.ini
@@ -1,8 +1,6 @@
 [mediasource-config-change-mp4-v-bitrate.html]
   type: testharness
   prefs: [media.mediasource.enabled:true]
-  [Tests mp4 video-only bitrate changes.]
-    expected:
-      if os == "linux": FAIL
-      if (os == "win") and (version == "5.1.2600"): FAIL
-
+  disabled:
+    if os == "linux": https://bugzilla.mozilla.org/show_bug.cgi?id=1188806
+    if (os == "win") and (version == "5.1.2600"): https://bugzilla.mozilla.org/show_bug.cgi?id=1188806
--- a/testing/web-platform/meta/media-source/mediasource-config-change-mp4-v-framerate.html.ini
+++ b/testing/web-platform/meta/media-source/mediasource-config-change-mp4-v-framerate.html.ini
@@ -1,8 +1,6 @@
 [mediasource-config-change-mp4-v-framerate.html]
   type: testharness
   prefs: [media.mediasource.enabled:true]
-  [Tests mp4 video-only frame rate changes.]
-    expected:
-      if os == "linux": FAIL
-      if (os == "win") and (version == "5.1.2600"): FAIL
-
+  disabled:
+    if os == "linux": https://bugzilla.mozilla.org/show_bug.cgi?id=1188806
+    if (os == "win") and (version == "5.1.2600"): https://bugzilla.mozilla.org/show_bug.cgi?id=1188806
--- a/testing/web-platform/meta/media-source/mediasource-config-change-mp4-v-framesize.html.ini
+++ b/testing/web-platform/meta/media-source/mediasource-config-change-mp4-v-framesize.html.ini
@@ -1,8 +1,6 @@
 [mediasource-config-change-mp4-v-framesize.html]
   type: testharness
   prefs: [media.mediasource.enabled:true]
-  [Tests mp4 video-only frame size changes.]
-    expected:
-      if os == "linux": FAIL
-      if (os == "win") and (version == "5.1.2600"): FAIL
-
+  disabled:
+    if os == "linux": https://bugzilla.mozilla.org/show_bug.cgi?id=1188806
+    if (os == "win") and (version == "5.1.2600"): https://bugzilla.mozilla.org/show_bug.cgi?id=1188806