Bug 1238430 - Enable WPT websocket tests that use WSS. r=mcmanus
authorJosh Matthews <josh@joshmatthews.net>
Fri, 26 Feb 2016 18:57:13 -0500
changeset 322538 47edc016cd4a5afeb579b0c4ec86292484916cdb
parent 322537 017122d17ff039ada9efdafc1582f530bbcfa0c4
child 322539 74a8cd912dcd154cdfd0c771d7d4ea73f016191e
push id5913
push userjlund@mozilla.com
push dateMon, 25 Apr 2016 16:57:49 +0000
treeherdermozilla-beta@dcaf0a6fa115 [default view] [failures only]
perfherder[talos] [build metrics] [platform microbench] (compared to previous push)
reviewersmcmanus
bugs1238430
milestone47.0a1
first release with
nightly linux32
nightly linux64
nightly mac
nightly win32
nightly win64
last release without
nightly linux32
nightly linux64
nightly mac
nightly win32
nightly win64
Bug 1238430 - Enable WPT websocket tests that use WSS. r=mcmanus
testing/web-platform/meta/websockets/Create-Secure-extensions-empty.htm.ini
testing/web-platform/meta/websockets/Create-Secure-valid-url-array-protocols.htm.ini
testing/web-platform/meta/websockets/Create-Secure-valid-url-binaryType-blob.htm.ini
testing/web-platform/meta/websockets/Create-Secure-valid-url-protocol-setCorrectly.htm.ini
testing/web-platform/meta/websockets/Create-Secure-valid-url-protocol-string.htm.ini
testing/web-platform/meta/websockets/Create-Secure-valid-url.htm.ini
testing/web-platform/meta/websockets/Secure-Close-0.htm.ini
testing/web-platform/meta/websockets/Secure-Close-1000-reason.htm.ini
testing/web-platform/meta/websockets/Secure-Close-1000-verify-code.htm.ini
testing/web-platform/meta/websockets/Secure-Close-1000.htm.ini
testing/web-platform/meta/websockets/Secure-Close-1005-verify-code.htm.ini
testing/web-platform/meta/websockets/Secure-Close-1005.htm.ini
testing/web-platform/meta/websockets/Secure-Close-2999-reason.htm.ini
testing/web-platform/meta/websockets/Secure-Close-3000-reason.htm.ini
testing/web-platform/meta/websockets/Secure-Close-3000-verify-code.htm.ini
testing/web-platform/meta/websockets/Secure-Close-4999-reason.htm.ini
testing/web-platform/meta/websockets/Secure-Close-NaN.htm.ini
testing/web-platform/meta/websockets/Secure-Close-Reason-124Bytes.htm.ini
testing/web-platform/meta/websockets/Secure-Close-Reason-Unpaired-surrogates.htm.ini
testing/web-platform/meta/websockets/Secure-Close-null.htm.ini
testing/web-platform/meta/websockets/Secure-Close-onlyReason.htm.ini
testing/web-platform/meta/websockets/Secure-Close-readyState-Closed.htm.ini
testing/web-platform/meta/websockets/Secure-Close-readyState-Closing.htm.ini
testing/web-platform/meta/websockets/Secure-Close-server-initiated-close.htm.ini
testing/web-platform/meta/websockets/Secure-Close-string.htm.ini
testing/web-platform/meta/websockets/Secure-Close-undefined.htm.ini
testing/web-platform/meta/websockets/Secure-Send-65K-data.htm.ini
testing/web-platform/meta/websockets/Secure-Send-binary-65K-arraybuffer.htm.ini
testing/web-platform/meta/websockets/Secure-Send-binary-arraybuffer.htm.ini
testing/web-platform/meta/websockets/Secure-Send-binary-arraybufferview-float64.htm.ini
testing/web-platform/meta/websockets/Secure-Send-binary-arraybufferview-int32.htm.ini
testing/web-platform/meta/websockets/Secure-Send-binary-arraybufferview-uint16-offset-length.htm.ini
testing/web-platform/meta/websockets/Secure-Send-binary-arraybufferview-uint32-offset.htm.ini
testing/web-platform/meta/websockets/Secure-Send-binary-arraybufferview-uint8-offset-length.htm.ini
testing/web-platform/meta/websockets/Secure-Send-binary-arraybufferview-uint8-offset.htm.ini
testing/web-platform/meta/websockets/Secure-Send-binary-blob.htm.ini
testing/web-platform/meta/websockets/Secure-Send-data.htm.ini
testing/web-platform/meta/websockets/Secure-Send-null.htm.ini
testing/web-platform/meta/websockets/Secure-Send-paired-surrogates.htm.ini
testing/web-platform/meta/websockets/Secure-Send-unicode-data.htm.ini
testing/web-platform/meta/websockets/Secure-Send-unpaired-surrogates.htm.ini
--- a/testing/web-platform/meta/websockets/Create-Secure-extensions-empty.htm.ini
+++ b/testing/web-platform/meta/websockets/Create-Secure-extensions-empty.htm.ini
@@ -1,10 +1,7 @@
 [Create-Secure-extensions-empty.htm]
   type: testharness
-  expected: ERROR
-  disabled: https://bugzilla.mozilla.org/show_bug.cgi?id=1025066
+  expected: TIMEOUT
   [W3C WebSocket API - Create Secure WebSocket - wsocket.extensions should be set to '' after connection is established - Connection should be opened]
-    expected: NOTRUN
-
+    expected: FAIL
   [W3C WebSocket API - Create Secure WebSocket - wsocket.extensions should be set to '' after connection is established - Connection should be closed]
     expected: NOTRUN
-
deleted file mode 100644
--- a/testing/web-platform/meta/websockets/Create-Secure-valid-url-array-protocols.htm.ini
+++ /dev/null
@@ -1,10 +0,0 @@
-[Create-Secure-valid-url-array-protocols.htm]
-  type: testharness
-  expected: ERROR
-  disabled: https://bugzilla.mozilla.org/show_bug.cgi?id=1025066
-  [W3C WebSocket API - Create Secure WebSocket - Pass a valid URL and array of protocol strings - Connection should be opened]
-    expected: NOTRUN
-
-  [W3C WebSocket API - Create Secure WebSocket - Pass a valid URL and array of protocol strings - Connection should be closed]
-    expected: NOTRUN
-
deleted file mode 100644
--- a/testing/web-platform/meta/websockets/Create-Secure-valid-url-binaryType-blob.htm.ini
+++ /dev/null
@@ -1,10 +0,0 @@
-[Create-Secure-valid-url-binaryType-blob.htm]
-  type: testharness
-  expected: ERROR
-  disabled: https://bugzilla.mozilla.org/show_bug.cgi?id=1025066
-  [W3C WebSocket API - Create Secure WebSocket - wsocket.binaryType should be set to 'blob' after connection is established - Connection should be opened]
-    expected: NOTRUN
-
-  [W3C WebSocket API - Create Secure WebSocket - wsocket.binaryType should be set to 'blob' after connection is established - Connection should be closed]
-    expected: NOTRUN
-
deleted file mode 100644
--- a/testing/web-platform/meta/websockets/Create-Secure-valid-url-protocol-setCorrectly.htm.ini
+++ /dev/null
@@ -1,10 +0,0 @@
-[Create-Secure-valid-url-protocol-setCorrectly.htm]
-  type: testharness
-  expected: ERROR
-  disabled: https://bugzilla.mozilla.org/show_bug.cgi?id=1025066
-  [W3C WebSocket API - Create Secure WebSocket - Pass a valid URL and protocol string - protocol should be set correctly - Connection should be opened]
-    expected: NOTRUN
-
-  [W3C WebSocket API - Create Secure WebSocket - Pass a valid URL and protocol string - Connection should be closed]
-    expected: NOTRUN
-
deleted file mode 100644
--- a/testing/web-platform/meta/websockets/Create-Secure-valid-url-protocol-string.htm.ini
+++ /dev/null
@@ -1,10 +0,0 @@
-[Create-Secure-valid-url-protocol-string.htm]
-  type: testharness
-  expected: ERROR
-  disabled: https://bugzilla.mozilla.org/show_bug.cgi?id=1025066
-  [W3C WebSocket API - Create Secure WebSocket - Check readyState is 1]
-    expected: NOTRUN
-
-  [W3C WebSocket API - Create Secure WebSocket - Pass a valid URL and protocol string - Connection should be closed]
-    expected: NOTRUN
-
deleted file mode 100644
--- a/testing/web-platform/meta/websockets/Create-Secure-valid-url.htm.ini
+++ /dev/null
@@ -1,10 +0,0 @@
-[Create-Secure-valid-url.htm]
-  type: testharness
-  expected: ERROR
-  disabled: https://bugzilla.mozilla.org/show_bug.cgi?id=1025066
-  [W3C WebSocket API - Create Secure WebSocket - Pass a valid URL  - Connection should be opened]
-    expected: NOTRUN
-
-  [W3C WebSocket API - Create Secure WebSocket - Pass a valid URL - Connection should be closed]
-    expected: NOTRUN
-
deleted file mode 100644
--- a/testing/web-platform/meta/websockets/Secure-Close-0.htm.ini
+++ /dev/null
@@ -1,7 +0,0 @@
-[Secure-Close-0.htm]
-  type: testharness
-  expected: ERROR
-  disabled: https://bugzilla.mozilla.org/show_bug.cgi?id=1025066
-  [W3C WebSocket API - Create Secure WebSocket - Close the Connection - close(0) - INVALID_ACCESS_ERR is thrown]
-    expected: NOTRUN
-
deleted file mode 100644
--- a/testing/web-platform/meta/websockets/Secure-Close-1000-reason.htm.ini
+++ /dev/null
@@ -1,10 +0,0 @@
-[Secure-Close-1000-reason.htm]
-  type: testharness
-  expected: ERROR
-  disabled: https://bugzilla.mozilla.org/show_bug.cgi?id=1025066
-  [W3C WebSocket API - Create Secure WebSocket - Close the Connection - close(1000, reason) - Connection should be opened]
-    expected: NOTRUN
-
-  [W3C WebSocket API - Create Secure WebSocket - Close the Connection - close(1000, reason) - readyState should be in CLOSED state and wasClean is TRUE - Connection should be closed]
-    expected: NOTRUN
-
deleted file mode 100644
--- a/testing/web-platform/meta/websockets/Secure-Close-1000-verify-code.htm.ini
+++ /dev/null
@@ -1,10 +0,0 @@
-[Secure-Close-1000-verify-code.htm]
-  type: testharness
-  expected: ERROR
-  disabled: https://bugzilla.mozilla.org/show_bug.cgi?id=1025066
-  [W3C WebSocket API - Create Secure WebSocket - Close the Connection - close(1000, reason) - Connection should be opened]
-    expected: NOTRUN
-
-  [W3C WebSocket API - Create Secure WebSocket - Close the Connection - close(1000, reason) - event.code == 1000 and event.reason = 'Clean Close']
-    expected: NOTRUN
-
deleted file mode 100644
--- a/testing/web-platform/meta/websockets/Secure-Close-1000.htm.ini
+++ /dev/null
@@ -1,10 +0,0 @@
-[Secure-Close-1000.htm]
-  type: testharness
-  expected: ERROR
-  disabled: https://bugzilla.mozilla.org/show_bug.cgi?id=1025066
-  [W3C WebSocket API - Create Secure WebSocket - Close the Connection - close(1000) - Connection should be opened]
-    expected: NOTRUN
-
-  [W3C WebSocket API - Create Secure WebSocket - Close the Connection - close(1000) - readyState should be in CLOSED state and wasClean is TRUE - Connection should be closed]
-    expected: NOTRUN
-
deleted file mode 100644
--- a/testing/web-platform/meta/websockets/Secure-Close-1005-verify-code.htm.ini
+++ /dev/null
@@ -1,10 +0,0 @@
-[Secure-Close-1005-verify-code.htm]
-  type: testharness
-  expected: ERROR
-  disabled: https://bugzilla.mozilla.org/show_bug.cgi?id=1025066
-  [W3C WebSocket API - Create Secure WebSocket - Close the Connection - close() - Connection should be opened]
-    expected: NOTRUN
-
-  [W3C WebSocket API - Create Secure WebSocket - Close the Connection - close() - return close code is 1005 - Connection should be closed]
-    expected: NOTRUN
-
deleted file mode 100644
--- a/testing/web-platform/meta/websockets/Secure-Close-1005.htm.ini
+++ /dev/null
@@ -1,7 +0,0 @@
-[Secure-Close-1005.htm]
-  type: testharness
-  expected: ERROR
-  disabled: https://bugzilla.mozilla.org/show_bug.cgi?id=1025066
-  [W3C WebSocket API - Create Secure WebSocket - Close the Connection - close(1005) - see '7.1.5.  The WebSocket Connection Close Code' in http://www.ietf.org/rfc/rfc6455.txt]
-    expected: NOTRUN
-
deleted file mode 100644
--- a/testing/web-platform/meta/websockets/Secure-Close-2999-reason.htm.ini
+++ /dev/null
@@ -1,7 +0,0 @@
-[Secure-Close-2999-reason.htm]
-  type: testharness
-  expected: ERROR
-  disabled: https://bugzilla.mozilla.org/show_bug.cgi?id=1025066
-  [W3C WebSocket API - Create Secure WebSocket - Close the Connection - close(2999, reason) - INVALID_ACCESS_ERR is thrown]
-    expected: NOTRUN
-
deleted file mode 100644
--- a/testing/web-platform/meta/websockets/Secure-Close-3000-reason.htm.ini
+++ /dev/null
@@ -1,10 +0,0 @@
-[Secure-Close-3000-reason.htm]
-  type: testharness
-  expected: ERROR
-  disabled: https://bugzilla.mozilla.org/show_bug.cgi?id=1025066
-  [W3C WebSocket API - Create Secure WebSocket - Close the Connection - close(3000, reason) - Connection should be opened]
-    expected: NOTRUN
-
-  [W3C WebSocket API - Create Secure WebSocket - Close the Connection - close(3000, reason) - readyState should be in CLOSED state and wasClean is TRUE - Connection should be closed]
-    expected: NOTRUN
-
deleted file mode 100644
--- a/testing/web-platform/meta/websockets/Secure-Close-3000-verify-code.htm.ini
+++ /dev/null
@@ -1,10 +0,0 @@
-[Secure-Close-3000-verify-code.htm]
-  type: testharness
-  expected: ERROR
-  disabled: https://bugzilla.mozilla.org/show_bug.cgi?id=1025066
-  [W3C WebSocket API - Create Secure WebSocket - Close the Connection - close(3000, reason) - Connection should be opened]
-    expected: NOTRUN
-
-  [W3C WebSocket API - Create Secure WebSocket - Close the Connection - close(3000, reason) - verify return code is 3000 - Connection should be closed]
-    expected: NOTRUN
-
deleted file mode 100644
--- a/testing/web-platform/meta/websockets/Secure-Close-4999-reason.htm.ini
+++ /dev/null
@@ -1,10 +0,0 @@
-[Secure-Close-4999-reason.htm]
-  type: testharness
-  expected: ERROR
-  disabled: https://bugzilla.mozilla.org/show_bug.cgi?id=1025066
-  [W3C WebSocket API - Create Secure WebSocket - Close the Connection - close(4999, reason) - Connection should be opened]
-    expected: NOTRUN
-
-  [W3C WebSocket API - Create Secure WebSocket - Close the Connection - close(4999, reason) - readyState should be in CLOSED state and wasClean is TRUE - Connection should be closed]
-    expected: NOTRUN
-
deleted file mode 100644
--- a/testing/web-platform/meta/websockets/Secure-Close-NaN.htm.ini
+++ /dev/null
@@ -1,7 +0,0 @@
-[Secure-Close-NaN.htm]
-  type: testharness
-  expected: ERROR
-  disabled: https://bugzilla.mozilla.org/show_bug.cgi?id=1025066
-  [W3C WebSocket API - Create WebSocket - Close the Connection - close(NaN) - INVALID_ACCESS_ERR is thrown]
-    expected: NOTRUN
-
deleted file mode 100644
--- a/testing/web-platform/meta/websockets/Secure-Close-Reason-124Bytes.htm.ini
+++ /dev/null
@@ -1,7 +0,0 @@
-[Secure-Close-Reason-124Bytes.htm]
-  type: testharness
-  expected: ERROR
-  disabled: https://bugzilla.mozilla.org/show_bug.cgi?id=1025066
-  [W3C WebSocket API - Create Secure WebSocket - Close the Connection - close(code, 'reason more than 123 bytes') - SYNTAX_ERR is thrown]
-    expected: NOTRUN
-
deleted file mode 100644
--- a/testing/web-platform/meta/websockets/Secure-Close-Reason-Unpaired-surrogates.htm.ini
+++ /dev/null
@@ -1,10 +0,0 @@
-[Secure-Close-Reason-Unpaired-surrogates.htm]
-  type: testharness
-  expected: ERROR
-  disabled: https://bugzilla.mozilla.org/show_bug.cgi?id=1025066
-  [W3C WebSocket API - Create Secure WebSocket - Close the Connection - close(reason with unpaired surrogates) - connection should get opened]
-    expected: NOTRUN
-
-  [W3C WebSocket API - Create Secure WebSocket - Close the Connection - close(reason with unpaired surrogates) - connection should get closed]
-    expected: NOTRUN
-
deleted file mode 100644
--- a/testing/web-platform/meta/websockets/Secure-Close-null.htm.ini
+++ /dev/null
@@ -1,7 +0,0 @@
-[Secure-Close-null.htm]
-  type: testharness
-  expected: ERROR
-  disabled: https://bugzilla.mozilla.org/show_bug.cgi?id=1025066
-  [W3C WebSocket API - Create WebSocket - Close the Connection - close(null) - INVALID_ACCESS_ERR is thrown]
-    expected: NOTRUN
-
deleted file mode 100644
--- a/testing/web-platform/meta/websockets/Secure-Close-onlyReason.htm.ini
+++ /dev/null
@@ -1,7 +0,0 @@
-[Secure-Close-onlyReason.htm]
-  type: testharness
-  expected: ERROR
-  disabled: https://bugzilla.mozilla.org/show_bug.cgi?id=1025066
-  [W3C WebSocket API - Create Secure WebSocket - Close the Connection - close(only reason) - INVALID_ACCESS_ERR is thrown]
-    expected: NOTRUN
-
deleted file mode 100644
--- a/testing/web-platform/meta/websockets/Secure-Close-readyState-Closed.htm.ini
+++ /dev/null
@@ -1,10 +0,0 @@
-[Secure-Close-readyState-Closed.htm]
-  type: testharness
-  expected: ERROR
-  disabled: https://bugzilla.mozilla.org/show_bug.cgi?id=1025066
-  [W3C WebSocket API - Create Secure WebSocket - Close the Connection - Connection should be opened]
-    expected: NOTRUN
-
-  [W3C WebSocket API - Create Secure WebSocket - Close the Connection - readyState should be in CLOSED state and wasClean is TRUE - Connection should be closed]
-    expected: NOTRUN
-
deleted file mode 100644
--- a/testing/web-platform/meta/websockets/Secure-Close-readyState-Closing.htm.ini
+++ /dev/null
@@ -1,7 +0,0 @@
-[Secure-Close-readyState-Closing.htm]
-  type: testharness
-  expected: ERROR
-  disabled: https://bugzilla.mozilla.org/show_bug.cgi?id=1025066
-  [W3C WebSocket API - Create Secure WebSocket - Close the Connection - readyState should be in CLOSING state just before onclose is called]
-    expected: NOTRUN
-
deleted file mode 100644
--- a/testing/web-platform/meta/websockets/Secure-Close-server-initiated-close.htm.ini
+++ /dev/null
@@ -1,10 +0,0 @@
-[Secure-Close-server-initiated-close.htm]
-  type: testharness
-  expected: ERROR
-  disabled: https://bugzilla.mozilla.org/show_bug.cgi?id=1025066
-  [W3C WebSocket API - Create Secure WebSocket - Server initiated Close - Client sends back a CLOSE - Connection should be opened]
-    expected: NOTRUN
-
-  [W3C WebSocket API - Create Secure WebSocket - Server initiated Close - Client sends back a CLOSE - readyState should be in CLOSED state and wasClean is TRUE - Connection should be closed]
-    expected: NOTRUN
-
deleted file mode 100644
--- a/testing/web-platform/meta/websockets/Secure-Close-string.htm.ini
+++ /dev/null
@@ -1,7 +0,0 @@
-[Secure-Close-string.htm]
-  type: testharness
-  expected: ERROR
-  disabled: https://bugzilla.mozilla.org/show_bug.cgi?id=1025066
-  [W3C WebSocket API - Create WebSocket - Close the Connection - close(string) - INVALID_ACCESS_ERR is thrown]
-    expected: NOTRUN
-
deleted file mode 100644
--- a/testing/web-platform/meta/websockets/Secure-Close-undefined.htm.ini
+++ /dev/null
@@ -1,7 +0,0 @@
-[Secure-Close-undefined.htm]
-  type: testharness
-  expected: ERROR
-  disabled: https://bugzilla.mozilla.org/show_bug.cgi?id=1025066
-  [W3C WebSocket API - Create Secure WebSocket - Close the Connection - close(undefined) - INVALID_ACCESS_ERR is thrown]
-    expected: NOTRUN
-
deleted file mode 100644
--- a/testing/web-platform/meta/websockets/Secure-Send-65K-data.htm.ini
+++ /dev/null
@@ -1,13 +0,0 @@
-[Secure-Send-65K-data.htm]
-  type: testharness
-  expected: ERROR
-  disabled: https://bugzilla.mozilla.org/show_bug.cgi?id=1025066
-  [W3C WebSocket API - Send  65K data on a Secure WebSocket - Connection should be opened]
-    expected: NOTRUN
-
-  [W3C WebSocket API - Send 65K data on a Secure WebSocket - Message should be received]
-    expected: NOTRUN
-
-  [W3C WebSocket API - Send 65K data on a Secure WebSocket - Connection should be closed]
-    expected: NOTRUN
-
deleted file mode 100644
--- a/testing/web-platform/meta/websockets/Secure-Send-binary-65K-arraybuffer.htm.ini
+++ /dev/null
@@ -1,13 +0,0 @@
-[Secure-Send-binary-65K-arraybuffer.htm]
-  type: testharness
-  expected: ERROR
-  disabled: https://bugzilla.mozilla.org/show_bug.cgi?id=1025066
-  [W3C WebSocket API - Send 65K binary data on a Secure WebSocket - ArrayBuffer - Connection should be opened]
-    expected: NOTRUN
-
-  [W3C WebSocket API - Send 65K binary data on a Secure WebSocket - ArrayBuffer - Message should be received]
-    expected: NOTRUN
-
-  [W3C WebSocket API - Send 65K binary data on a Secure WebSocket - ArrayBuffer - Connection should be closed]
-    expected: NOTRUN
-
deleted file mode 100644
--- a/testing/web-platform/meta/websockets/Secure-Send-binary-arraybuffer.htm.ini
+++ /dev/null
@@ -1,13 +0,0 @@
-[Secure-Send-binary-arraybuffer.htm]
-  type: testharness
-  expected: ERROR
-  disabled: https://bugzilla.mozilla.org/show_bug.cgi?id=1025066
-  [W3C WebSocket API - Send binary data on a Secure WebSocket - ArrayBuffer - Connection should be opened]
-    expected: NOTRUN
-
-  [W3C WebSocket API - Send binary data on a Secure WebSocket - ArrayBuffer - Message should be received]
-    expected: NOTRUN
-
-  [W3C WebSocket API - Send binary data on a Secure WebSocket - ArrayBuffer - Connection should be closed]
-    expected: NOTRUN
-
deleted file mode 100644
--- a/testing/web-platform/meta/websockets/Secure-Send-binary-arraybufferview-float64.htm.ini
+++ /dev/null
@@ -1,13 +0,0 @@
-[Secure-Send-binary-arraybufferview-float64.htm]
-  type: testharness
-  expected: ERROR
-  disabled: https://bugzilla.mozilla.org/show_bug.cgi?id=1025066
-  [W3C WebSocket API - Send binary data on a WebSocket - ArrayBufferView - Float64Array - Connection should be opened]
-    expected: NOTRUN
-
-  [W3C WebSocket API - Send binary data on a WebSocket - ArrayBufferView - Float64Array - Message should be received]
-    expected: NOTRUN
-
-  [W3C WebSocket API - Send binary data on a WebSocket - ArrayBufferView - Float64Array - Connection should be closed]
-    expected: NOTRUN
-
deleted file mode 100644
--- a/testing/web-platform/meta/websockets/Secure-Send-binary-arraybufferview-int32.htm.ini
+++ /dev/null
@@ -1,13 +0,0 @@
-[Secure-Send-binary-arraybufferview-int32.htm]
-  type: testharness
-  expected: ERROR
-  disabled: https://bugzilla.mozilla.org/show_bug.cgi?id=1025066
-  [W3C WebSocket API - Send binary data on a WebSocket - ArrayBufferView - Int32Array - Connection should be opened]
-    expected: NOTRUN
-
-  [W3C WebSocket API - Send binary data on a WebSocket - ArrayBufferView - Int32Array - Message should be received]
-    expected: NOTRUN
-
-  [W3C WebSocket API - Send binary data on a WebSocket - ArrayBufferView - Int32Array - Connection should be closed]
-    expected: NOTRUN
-
deleted file mode 100644
--- a/testing/web-platform/meta/websockets/Secure-Send-binary-arraybufferview-uint16-offset-length.htm.ini
+++ /dev/null
@@ -1,13 +0,0 @@
-[Secure-Send-binary-arraybufferview-uint16-offset-length.htm]
-  type: testharness
-  disabled: https://bugzilla.mozilla.org/show_bug.cgi?id=1025066
-  expected: ERROR
-  [W3C WebSocket API - Send binary data on a WebSocket - ArrayBufferView - Uint16Array with offset and length - Connection should be opened]
-    expected: NOTRUN
-
-  [W3C WebSocket API - Send binary data on a WebSocket - ArrayBufferView - Uint16Array with offset and length - Message should be received]
-    expected: NOTRUN
-
-  [W3C WebSocket API - Send binary data on a WebSocket - ArrayBufferView - Uint16Array with offset and length - Connection should be closed]
-    expected: NOTRUN
-
deleted file mode 100644
--- a/testing/web-platform/meta/websockets/Secure-Send-binary-arraybufferview-uint32-offset.htm.ini
+++ /dev/null
@@ -1,13 +0,0 @@
-[Secure-Send-binary-arraybufferview-uint32-offset.htm]
-  type: testharness
-  disabled: https://bugzilla.mozilla.org/show_bug.cgi?id=1025066
-  expected: ERROR
-  [W3C WebSocket API - Send binary data on a WebSocket - ArrayBufferView - Uint32Array with offset - Connection should be opened]
-    expected: NOTRUN
-
-  [W3C WebSocket API - Send binary data on a WebSocket - ArrayBufferView - Uint32Array with offset - Message should be received]
-    expected: NOTRUN
-
-  [W3C WebSocket API - Send binary data on a WebSocket - ArrayBufferView - Uint32Array with offset - Connection should be closed]
-    expected: NOTRUN
-
deleted file mode 100644
--- a/testing/web-platform/meta/websockets/Secure-Send-binary-arraybufferview-uint8-offset-length.htm.ini
+++ /dev/null
@@ -1,13 +0,0 @@
-[Secure-Send-binary-arraybufferview-uint8-offset-length.htm]
-  type: testharness
-  disabled: https://bugzilla.mozilla.org/show_bug.cgi?id=1025066
-  expected: ERROR
-  [W3C WebSocket API - Send binary data on a WebSocket - ArrayBufferView - Uint8Array with offset and length - Connection should be opened]
-    expected: NOTRUN
-
-  [W3C WebSocket API - Send binary data on a WebSocket - ArrayBufferView - Uint8Array with offset and length - Message should be received]
-    expected: NOTRUN
-
-  [W3C WebSocket API - Send binary data on a WebSocket - ArrayBufferView - Uint8Array with offset and length - Connection should be closed]
-    expected: NOTRUN
-
deleted file mode 100644
--- a/testing/web-platform/meta/websockets/Secure-Send-binary-arraybufferview-uint8-offset.htm.ini
+++ /dev/null
@@ -1,13 +0,0 @@
-[Secure-Send-binary-arraybufferview-uint8-offset.htm]
-  type: testharness
-  disabled: https://bugzilla.mozilla.org/show_bug.cgi?id=1025066
-  expected: ERROR
-  [W3C WebSocket API - Send binary data on a WebSocket - ArrayBufferView - Uint8Array with offset - Connection should be opened]
-    expected: NOTRUN
-
-  [W3C WebSocket API - Send binary data on a WebSocket - ArrayBufferView - Uint8Array with offset - Message should be received]
-    expected: NOTRUN
-
-  [W3C WebSocket API - Send binary data on a WebSocket - ArrayBufferView - Uint8Array with offset - Connection should be closed]
-    expected: NOTRUN
-
deleted file mode 100644
--- a/testing/web-platform/meta/websockets/Secure-Send-binary-blob.htm.ini
+++ /dev/null
@@ -1,13 +0,0 @@
-[Secure-Send-binary-blob.htm]
-  type: testharness
-  disabled: https://bugzilla.mozilla.org/show_bug.cgi?id=1025066
-  expected: ERROR
-  [W3C WebSocket API - Send binary data on a Secure WebSocket - Blob - Connection should be opened]
-    expected: NOTRUN
-
-  [W3C WebSocket API - Send binary data on a Secure WebSocket - Blob - Message should be received]
-    expected: NOTRUN
-
-  [W3C WebSocket API - Send binary data on a Secure WebSocket - Blob - Connection should be closed]
-    expected: NOTRUN
-
deleted file mode 100644
--- a/testing/web-platform/meta/websockets/Secure-Send-data.htm.ini
+++ /dev/null
@@ -1,13 +0,0 @@
-[Secure-Send-data.htm]
-  type: testharness
-  disabled: https://bugzilla.mozilla.org/show_bug.cgi?id=1025066
-  expected: ERROR
-  [W3C WebSocket API - Send  data on a Secure WebSocket - Connection should be opened]
-    expected: NOTRUN
-
-  [W3C WebSocket API - Send data on a Secure WebSocket - Message should be received]
-    expected: NOTRUN
-
-  [W3C WebSocket API - Send data on a Secure WebSocket - Connection should be closed]
-    expected: NOTRUN
-
deleted file mode 100644
--- a/testing/web-platform/meta/websockets/Secure-Send-null.htm.ini
+++ /dev/null
@@ -1,13 +0,0 @@
-[Secure-Send-null.htm]
-  type: testharness
-  disabled: https://bugzilla.mozilla.org/show_bug.cgi?id=1025066
-  expected: ERROR
-  [W3C WebSocket API - Send null data on a Secure WebSocket - Connection should be opened]
-    expected: NOTRUN
-
-  [W3C WebSocket API - Send null data on a Secure WebSocket - Message should be received]
-    expected: NOTRUN
-
-  [W3C WebSocket API - Send null data on a Secure WebSocket - Connection should be closed]
-    expected: NOTRUN
-
deleted file mode 100644
--- a/testing/web-platform/meta/websockets/Secure-Send-paired-surrogates.htm.ini
+++ /dev/null
@@ -1,13 +0,0 @@
-[Secure-Send-paired-surrogates.htm]
-  type: testharness
-  disabled: https://bugzilla.mozilla.org/show_bug.cgi?id=1025066
-  expected: ERROR
-  [W3C WebSocket API - Send paired surrogates data on a Secure WebSocket - Connection should be opened]
-    expected: NOTRUN
-
-  [W3C WebSocket API - Send paired surrogates data on a Secure WebSocket - Message should be received]
-    expected: NOTRUN
-
-  [W3C WebSocket API - Send paired surrogates data on a Secure WebSocket - Connection should be closed]
-    expected: NOTRUN
-
deleted file mode 100644
--- a/testing/web-platform/meta/websockets/Secure-Send-unicode-data.htm.ini
+++ /dev/null
@@ -1,13 +0,0 @@
-[Secure-Send-unicode-data.htm]
-  type: testharness
-  disabled: https://bugzilla.mozilla.org/show_bug.cgi?id=1025066
-  expected: ERROR
-  [W3C WebSocket API - Send  unicode data on a Secure WebSocket - Connection should be opened]
-    expected: NOTRUN
-
-  [W3C WebSocket API - Send unicode data on a Secure WebSocket - Message should be received]
-    expected: NOTRUN
-
-  [W3C WebSocket API - Send unicode data on a Secure WebSocket - Connection should be closed]
-    expected: NOTRUN
-
deleted file mode 100644
--- a/testing/web-platform/meta/websockets/Secure-Send-unpaired-surrogates.htm.ini
+++ /dev/null
@@ -1,13 +0,0 @@
-[Secure-Send-unpaired-surrogates.htm]
-  type: testharness
-  disabled: https://bugzilla.mozilla.org/show_bug.cgi?id=1025066
-  expected: ERROR
-  [W3C WebSocket API - Send unpaired surrogates on a Secure WebSocket - Connection should be opened]
-    expected: NOTRUN
-
-  [W3C WebSocket API - Send unpaired surrogates on a Secure WebSocket - Message should be received]
-    expected: NOTRUN
-
-  [W3C WebSocket API - Send unpaired surrogates on a Secure WebSocket - Connection should be closed]
-    expected: NOTRUN
-