Bug 1257870 - Require 1.5.0 --with-system-libvpx. r=glandium, a=lizzard
authorRalph Giles <giles@mozilla.com>
Mon, 28 Mar 2016 16:58:00 -0400
changeset 317695 106f1210a1b55f5e5e0ebeb9906be71792d13dcb
parent 317694 357236ebcff4e211f2d98589e25fd4574605959a
child 317696 bd3a8572be8677053ec95066251bc9efc47b5813
push id5849
push userryanvm@gmail.com
push dateSat, 02 Apr 2016 03:34:35 +0000
treeherdermozilla-beta@b19e6561f416 [default view] [failures only]
perfherder[talos] [build metrics] [platform microbench] (compared to previous push)
reviewersglandium, lizzard
bugs1257870, 1237023, 1248335
milestone46.0
Bug 1257870 - Require 1.5.0 --with-system-libvpx. r=glandium, a=lizzard WebRTC code requires VP9E_SET_NOISE_SENSITIVITY from vpx/vp8cx.h which was added in 1.4. We could feature test, but gating on the minimum version seems better given the m4 code is to be replaced by python. We also depend on VPX_MAX_LAYERS wich is part of the 1.5.0 release. This dependency was added with an SVC support patch in May 2015, bug 1237023. Optional --enable-spatial-svc is handled by the work-around in bug 1248335. MozReview-Commit-ID: 6NiZtKunBSm
configure.in
--- a/configure.in
+++ b/configure.in
@@ -5417,17 +5417,17 @@ fi
 
 _SAVE_CFLAGS=$CFLAGS
 _SAVE_LIBS=$LIBS
 if test -n "$MOZ_NATIVE_LIBVPX"; then
     dnl ============================
     dnl === libvpx Version check ===
     dnl ============================
     dnl Check to see if we have a system libvpx package.
-    PKG_CHECK_MODULES(MOZ_LIBVPX, vpx >= 1.3.0)
+    PKG_CHECK_MODULES(MOZ_LIBVPX, vpx >= 1.5.0)
 
     CFLAGS="$CFLAGS $MOZ_LIBVPX_CFLAGS"
     LIBS="$LIBS $MOZ_LIBVPX_LIBS"
 
     MOZ_CHECK_HEADER([vpx/vpx_decoder.h], [],
      [AC_MSG_ERROR([Couldn't find vpx/vpx_decoder.h which is required for build with system libvpx. Use --without-system-libvpx to build with in-tree libvpx.])])
 
     AC_CHECK_LIB(vpx, vpx_codec_dec_init_ver, [],