hal/HalScreenConfiguration.h
author Chris Manchester <cmanchester@mozilla.com>
Wed, 17 Aug 2016 15:02:31 -0700
changeset 351327 c0e6aae0b93dc05c08f909d809ad78a96944beeb
parent 210299 fcf15eb82338c3339cb39066828467b504ccc1a1
child 489057 000a3f46f36c9c400d35af815c7b19a9db6f7a9a
permissions -rw-r--r--
Bug 1294803 - Move MOZ_SYSTEM_FFI to moz.configure in preparation for moving libffi to our build system. r=glandium This patch introduces a small change in behavior: we now unconditionally require libffi > 3.0.9 when using system ffi, rather than accepting 3.0.9 when using GCC, as 3.0.10 was released 5 years ago, and should be widely available. MozReview-Commit-ID: DtSDPoZSPcx

/* -*- Mode: C++; tab-width: 8; indent-tabs-mode: nil; c-basic-offset: 2 -*- */
/* vim: set sw=2 ts=8 et ft=cpp : */
/* This Source Code Form is subject to the terms of the Mozilla Public
 * License, v. 2.0. If a copy of the MPL was not distributed with this file,
 * You can obtain one at http://mozilla.org/MPL/2.0/. */

#ifndef mozilla_HalScreenConfiguration_h
#define mozilla_HalScreenConfiguration_h

#include "mozilla/Observer.h"

namespace mozilla {
namespace hal {
class ScreenConfiguration;
typedef Observer<ScreenConfiguration> ScreenConfigurationObserver;
} // namespace hal
} // namespace mozilla

#endif  // mozilla_HalScreenConfiguration_h