accessible/xul/moz.build
author Michael Comella <michael.l.comella@gmail.com>
Thu, 26 Feb 2015 10:47:14 -0800
changeset 250095 7ede0abc5a1c789059d1df337e758e8c73d35626
parent 244619 b14b9b335d4e1cf2a6e6ee0af1739b49506906ac
child 292691 c646a88160d7b65f755f4dcfa5dec8626a77bcd5
permissions -rw-r--r--
Bug 1135796 - Update ActivityUtils to use proper API levels. r=rnewman, a=lsblakk Fullscreen with the modern flags requires 4.1+ now; 4.0- is using the old flags.

# -*- Mode: python; c-basic-offset: 4; indent-tabs-mode: nil; tab-width: 40 -*-
# vim: set filetype=python:
# This Source Code Form is subject to the terms of the Mozilla Public
# License, v. 2.0. If a copy of the MPL was not distributed with this
# file, You can obtain one at http://mozilla.org/MPL/2.0/.

UNIFIED_SOURCES += [
    'XULAlertAccessible.cpp',
    'XULColorPickerAccessible.cpp',
    'XULComboboxAccessible.cpp',
    'XULElementAccessibles.cpp',
    'XULFormControlAccessible.cpp',
    'XULListboxAccessible.cpp',
    'XULMenuAccessible.cpp',
    'XULSelectControlAccessible.cpp',
    'XULSliderAccessible.cpp',
    'XULTabAccessible.cpp',
    'XULTreeAccessible.cpp',
    'XULTreeGridAccessible.cpp',
]

LOCAL_INCLUDES += [
    '/accessible/base',
    '/accessible/generic',
    '/accessible/html',
    '/accessible/xpcom',
    '/layout/generic',
    '/layout/xul',
    '/layout/xul/tree',
]

if CONFIG['MOZ_ENABLE_GTK']:
    LOCAL_INCLUDES += [
        '/accessible/atk',
    ]
elif CONFIG['MOZ_WIDGET_TOOLKIT'] == 'windows':
    LOCAL_INCLUDES += [
        '/accessible/windows/ia2',
        '/accessible/windows/msaa',
    ]
elif CONFIG['MOZ_WIDGET_TOOLKIT'] == 'cocoa':
    LOCAL_INCLUDES += [
        '/accessible/mac',
    ]
else:
    LOCAL_INCLUDES += [
        '/accessible/other',
    ]

FINAL_LIBRARY = 'xul'

FAIL_ON_WARNINGS = True