package.json
author Mike Hommey <mh+mozilla@glandium.org>
Tue, 28 Aug 2018 22:12:01 +0900
changeset 488825 2b045052d4aad4e77f3b8fce35a40efeed4e19f1
parent 485898 cbd1cebd5af9174c3e5be323c9e10b6d3a6089f2
child 493647 e9f354569cc1a8cf8639131feb0368f68b80375c
permissions -rw-r--r--
Bug 1485759 - Pass --build-id=sha1 to the linker instead of --build-id. r=froydnj BFD ld's --build-id means --build-id=sha1, but with lld it means --build-id=fast. Both support the explicit --build-id=sha1, so use that. Gold supports --build-id=sha1 too. ld64, used for mac builds doesn't support neither --build-id=sha1 nor --build-id.

{
  "name": "mozillaeslintsetup",
  "description": "This package file is for setup of ESLint only for editor integration.",
  "repository": {},
  "license": "MPL-2.0",
  "dependencies": {
    "eslint": "5.3.0",
    "eslint-plugin-html": "4.0.5",
    "eslint-plugin-mozilla": "file:tools/lint/eslint/eslint-plugin-mozilla",
    "eslint-plugin-no-unsanitized": "3.0.2",
    "eslint-plugin-react": "7.10.0",
    "eslint-plugin-spidermonkey-js": "file:tools/lint/eslint/eslint-plugin-spidermonkey-js"
  },
  "devDependencies": {}
}