Bug 759115 - Bump minimum Android SDK API level we require to 14. r=ted
☠☠ backed out by 65fa5cb6f79c ☠ ☠
authorMike Hommey <mh+mozilla@glandium.org>
Wed, 30 May 2012 09:36:25 +0200
changeset 99223 d8e75ef4e5adc2dae23c93dda334413e6beed269
parent 99222 4b57d0e8425563c39d9ec61754a56c4a1592d7b8
child 99224 65fa5cb6f79c0993ed0652d0751571b250d1469d
push idunknown
push userunknown
push dateunknown
reviewersted
bugs759115
milestone15.0a1
Bug 759115 - Bump minimum Android SDK API level we require to 14. r=ted
configure.in
--- a/configure.in
+++ b/configure.in
@@ -278,17 +278,17 @@ case "$target" in
     if test -z "$android_sdk" ; then
         AC_MSG_ERROR([You must specify --with-android-sdk=/path/to/sdk when targeting Android.])
     else
         if ! test -e "$android_sdk"/source.properties ; then
             AC_MSG_ERROR([The path in --with-android-sdk isn't valid (source.properties hasn't been found).])
         fi
 
         # Minimum Android SDK API Level we require.
-        android_min_api_level=13
+        android_min_api_level=14
 
         # Get the api level from "$android_sdk"/source.properties.
         android_api_level=`$AWK -F = '$1 == "AndroidVersion.ApiLevel" {print $2}' "$android_sdk"/source.properties`
 
         if test -z "$android_api_level" ; then
             AC_MSG_ERROR([Unexpected error: no AndroidVersion.ApiLevel field has been found in source.properties.])
         fi