Bug 1240530 - Bump the taskcluster version installed by |./mach artifact| to avoid installing an out-dated requests. r=nalexander
authorChris Manchester <cmanchester@mozilla.com>
Tue, 19 Jan 2016 16:00:11 -0800
changeset 303036 a1c1d5cf87ce86dcfeb414967e16ab37b7772bf4
parent 303035 417708054b36fcc7fc50156303b2221775dfb6f9
child 303037 6f84c75a07067e48c7fe4062cdd04b55ac48eb30
push id8978
push userraliiev@mozilla.com
push dateMon, 25 Jan 2016 14:05:32 +0000
treeherdermozilla-aurora@b9a803752a2c [default view] [failures only]
perfherder[talos] [build metrics] [platform microbench] (compared to previous push)
reviewersnalexander
bugs1240530
milestone46.0a1
Bug 1240530 - Bump the taskcluster version installed by |./mach artifact| to avoid installing an out-dated requests. r=nalexander Currently |./mach artifact| installs an old version of the taskcluster client, which installs an old version of requests that's incompatible with commonly installed python versions. This bumps to a version of taskcluster client that accepts and requests version < 3, so we pick up the in-tree version instead of installing 2.4.3.
python/mozbuild/mozbuild/mach_commands.py
--- a/python/mozbuild/mozbuild/mach_commands.py
+++ b/python/mozbuild/mozbuild/mach_commands.py
@@ -1442,17 +1442,17 @@ class PackageFrontend(MachCommandBase):
         pass
 
     def _set_log_level(self, verbose):
         self.log_manager.terminal_handler.setLevel(logging.INFO if not verbose else logging.DEBUG)
 
     def _make_artifacts(self, tree=None, job=None):
         self._activate_virtualenv()
         self.virtualenv_manager.install_pip_package('pylru==1.0.9')
-        self.virtualenv_manager.install_pip_package('taskcluster==0.0.16')
+        self.virtualenv_manager.install_pip_package('taskcluster==0.0.32')
         self.virtualenv_manager.install_pip_package('mozregression==1.0.2')
 
         state_dir = self._mach_context.state_dir
         cache_dir = os.path.join(state_dir, 'package-frontend')
 
         import which
         if self._is_windows():
           hg = which.which('hg.exe')