Bug 1256694 - Loop should use MOZ_APP_MAXVERSION to generate the maximum supported Firefox version number to correctly support security builds (build sytem part). r=glandium
authorMark Banner <standard8@mozilla.com>
Fri, 18 Mar 2016 09:31:56 +0000
changeset 313243 852ac8a4ec55b93df8c9740aafaee6b84f539c3d
parent 312952 3d37c7e5b8dd28a4a017e2296e824619f9379b88
child 313244 95656a398e8f7754d358f1f0250a2e8069f5db47
push id9480
push userjlund@mozilla.com
push dateMon, 25 Apr 2016 17:12:58 +0000
treeherdermozilla-aurora@0d6a91c76a9e [default view] [failures only]
perfherder[talos] [build metrics] [platform microbench] (compared to previous push)
reviewersglandium
bugs1256694
milestone48.0a1
Bug 1256694 - Loop should use MOZ_APP_MAXVERSION to generate the maximum supported Firefox version number to correctly support security builds (build sytem part). r=glandium
browser/extensions/loop/moz.build
--- a/browser/extensions/loop/moz.build
+++ b/browser/extensions/loop/moz.build
@@ -1,16 +1,18 @@
 # -*- Mode: python; c-basic-offset: 4; indent-tabs-mode: nil; tab-width: 40 -*-
 # vim: set filetype=python:
 # This Source Code Form is subject to the terms of the Mozilla Public
 # License, v. 2.0. If a copy of the MPL was not distributed with this
 # file, You can obtain one at http://mozilla.org/MPL/2.0/.
 
 DIRS += ['chrome/locale']
 
+DEFINES['MOZ_APP_MAXVERSION'] = CONFIG['MOZ_APP_MAXVERSION']
+
 FINAL_TARGET_FILES.features['loop@mozilla.org'] += [
  'bootstrap.js'
 ]
 
 FINAL_TARGET_PP_FILES.features['loop@mozilla.org'] += [
   'install.rdf.in'
 ]