Bug 933231 - don't |unset| variables after configuring NSPR; r=ted
authorNathan Froyd <froydnj@mozilla.com>
Fri, 08 Nov 2013 11:38:02 -0500
changeset 167826 838f865fa1c79d3733458400f932ebd46e1f74fc
parent 167825 724ff9cacbc1d9a092c11f544efae482a3611082
child 167827 ff49c9feb4664b938a76a1c7b9d78038c1d4100b
push id4703
push userakeybl@mozilla.com
push dateMon, 09 Dec 2013 20:24:19 +0000
treeherdermozilla-aurora@20af7fbd96c1 [default view] [failures only]
perfherder[talos] [build metrics] [platform microbench] (compared to previous push)
reviewersted
bugs933231
milestone28.0a1
Bug 933231 - don't |unset| variables after configuring NSPR; r=ted |unset|'ing these things causes them to not be exported to future configure's (JS's, especially, in this context). It's also completely unlike what we do with other _SAVE-style variables elsewhere in configure. Reassignment should be enough.
configure.in
--- a/configure.in
+++ b/configure.in
@@ -9122,19 +9122,16 @@ if test -z "$MOZ_NATIVE_NSPR"; then
       export CPPFLAGS="-include $_topsrcdir/mozglue/linker/dladdr.h $CPPFLAGS"
     fi
     export LDFLAGS="$LDFLAGS $NSPR_LDFLAGS"
     export CFLAGS="$CFLAGS $MOZ_FRAMEPTR_FLAGS"
 
     AC_OUTPUT_SUBDIRS(nsprpub)
 
     # .. and restore them
-    unset CFLAGS
-    unset CPPFLAGS
-    unset LDFLAGS
     CFLAGS="$_SAVE_CFLAGS"
     CPPFLAGS="$_SAVE_CPPFLAGS"
     LDFLAGS="$_SAVE_LDFLAGS"
 
     ac_configure_args="$_SUBDIR_CONFIG_ARGS"
 fi
 
 dnl ========================================================