Bug 1124667 - Release marionette-driver 0.2 and marionette-client 0.9. r=automatedtester, a=test-only
authorHenrik Skupin <mail@hskupin.info>
Thu, 26 Feb 2015 13:22:10 +0100
changeset 248239 758e5e0001831b40e1847e191dc47ad08f590545
parent 248238 5530b792f312b597128df48f3ba7a49e6ae64b19
child 248240 d9889bdeea0768f4b02d67ad5068f08aaac59c98
push id7791
push userdburns@mozilla.com
push dateFri, 20 Mar 2015 10:48:47 +0000
treeherdermozilla-aurora@758e5e000183 [default view] [failures only]
perfherder[talos] [build metrics] [platform microbench] (compared to previous push)
reviewersautomatedtester, test-only
bugs1124667
milestone38.0a2
Bug 1124667 - Release marionette-driver 0.2 and marionette-client 0.9. r=automatedtester, a=test-only
testing/marionette/client/requirements.txt
testing/marionette/client/setup.py
testing/marionette/driver/MANIFEST.in
testing/marionette/driver/setup.py
--- a/testing/marionette/client/requirements.txt
+++ b/testing/marionette/client/requirements.txt
@@ -1,10 +1,10 @@
 marionette-transport == 0.4
-marionette-driver == 0.1
+marionette-driver == 0.2
 manifestparser
 mozhttpd >= 0.5
 mozinfo >= 0.7
 mozprocess >= 0.9
 mozrunner >= 6.2
 mozdevice >= 0.44
 mozlog >= 2.7
 moznetwork >= 0.21
--- a/testing/marionette/client/setup.py
+++ b/testing/marionette/client/setup.py
@@ -1,32 +1,29 @@
-import os
 from setuptools import setup, find_packages
-import sys
 
-version = '0.8.7'
+version = '0.9'
 
 # dependencies
 with open('requirements.txt') as f:
     deps = f.read().splitlines()
 
 setup(name='marionette_client',
       version=version,
       description="Marionette test automation client",
       long_description='See http://marionette-client.readthedocs.org/',
-      classifiers=[], # Get strings from http://pypi.python.org/pypi?%3Aaction=list_classifiers
+      classifiers=[],  # Get strings from http://pypi.python.org/pypi?%3Aaction=list_classifiers
       keywords='mozilla',
       author='Jonathan Griffin',
       author_email='jgriffin@mozilla.com',
       url='https://wiki.mozilla.org/Auto-tools/Projects/Marionette',
       license='MPL',
       packages=find_packages(exclude=['ez_setup', 'examples', 'tests']),
       package_data={'marionette': ['touch/*.js']},
       include_package_data=True,
       zip_safe=False,
       entry_points="""
       # -*- Entry points: -*-
       [console_scripts]
       marionette = marionette.runtests:cli
       """,
       install_requires=deps,
       )
-
new file mode 100644
--- /dev/null
+++ b/testing/marionette/driver/MANIFEST.in
@@ -0,0 +1,2 @@
+exclude MANIFEST.in
+include requirements.txt
--- a/testing/marionette/driver/setup.py
+++ b/testing/marionette/driver/setup.py
@@ -1,27 +1,23 @@
-import os
 from setuptools import setup, find_packages
-import sys
 
-version = '0.1.0'
+version = '0.2'
 
 # dependencies
 with open('requirements.txt') as f:
     deps = f.read().splitlines()
 
 setup(name='marionette_driver',
       version=version,
       description="Marionette Driver",
       long_description='See http://marionette-driver.readthedocs.org/',
-      classifiers=[], # Get strings from http://pypi.python.org/pypi?%3Aaction=list_classifiers
+      classifiers=[],  # Get strings from http://pypi.python.org/pypi?%3Aaction=list_classifiers
       keywords='mozilla',
       author='Auto-tools',
       author_email='tools-marionette@lists.mozilla.org',
       url='https://wiki.mozilla.org/Auto-tools/Projects/Marionette',
       license='MPL',
       packages=find_packages(),
-      #package_data={'marionette_driver': ['touch/*.js']},
       include_package_data=True,
       zip_safe=False,
       install_requires=deps,
       )
-