servo/autogen.sh
author Brian J. Burg <burg@cs.washington.edu>
Wed, 05 Sep 2012 18:42:28 -0700
changeset 361874 1c499a3535ff575d53c1209ae31d6adf404944f5
parent 361587 a68e55f6b4239167ea61e7c125f0e437ad86b309
permissions -rwxr-xr-x
servo: Don't rebuild rust-core-foundation and rust-cocoa unless they are old Source-Repo: https://github.com/servo/servo Source-Revision: d25fecad92edee99a74b47f13f354b527383c200

#!/bin/bash

# Spidermonkey requires autoconf 2.13 exactly

if [ ! -z `which autoconf213` ]
then
    AUTOCONF213=autoconf213
fi

if [ ! -z `which autoconf2.13` ]
then
    AUTOCONF213=autoconf2.13
fi

if [ ! -z `which autoconf-2.13` ]
then
    AUTOCONF213=autoconf-2.13
fi

if [ -z "$AUTOCONF213" ]
then
    echo "I need autoconf 2.13"
fi

(cd src/mozjs/js/src && $AUTOCONF213) || exit $?

cp -f configure.in configure