Bug 1509586 - Look for requireEncryptMessage in params.smFields in msgCompSecurityInfo.js. r=mkmelin
authoraceman <acelists@atlas.sk>
Sun, 25 Nov 2018 11:55:00 +0100
changeset 33787 fab70cf9e35485946adfc8a507210a6f837c64e0
parent 33786 8199346174a7d9de8f882c52e3d02f9867eecc00
child 33788 35f0ac2f08163a9ffeadf5de6bb7c14be5ea6353
push id388
push userclokep@gmail.com
push dateMon, 28 Jan 2019 20:54:56 +0000
reviewersmkmelin
bugs1509586
Bug 1509586 - Look for requireEncryptMessage in params.smFields in msgCompSecurityInfo.js. r=mkmelin
mailnews/extensions/smime/content/msgCompSecurityInfo.js
--- a/mailnews/extensions/smime/content/msgCompSecurityInfo.js
+++ b/mailnews/extensions/smime/content/msgCompSecurityInfo.js
@@ -37,26 +37,17 @@ function onLoad()
 
   gEmailAddresses = new Object();
   gCertIssuedInfos = new Object();
   gCertExpiresInfos = new Object();
   gCerts = new Object();
   gCount = new Object();
   var canEncrypt = new Object();
 
-  var allow_ldap_cert_fetching = false;
-
-  try {
-    if (params.compFields.securityInfo.requireEncryptMessage) {
-      allow_ldap_cert_fetching = true;
-    }
-  }
-  catch (e)
-  {
-  }
+  var allow_ldap_cert_fetching = params.smFields.requireEncryptMessage;
 
   while (true)
   {
     try
     {
       helper.getRecipientCertsInfo(
         params.compFields,
         gCount,