Bug 1451097 - make add-ons in-compatible by default for TB 60 and beyond. r=jorgk a=jorgk
authorMagnus Melin <mkmelin+mozilla@iki.fi>
Tue, 03 Apr 2018 22:40:41 +0300
changeset 31340 dc12a66492b3be009ed136a084a1129c3ab5aed5
parent 31339 80d299efc73ba3440b371eaf3bb1375c15c53625
child 31341 503b7a647ba3f5c9072c6ce97b7e02199f408928
push id383
push userclokep@gmail.com
push dateMon, 07 May 2018 21:52:48 +0000
reviewersjorgk, jorgk
bugs1451097
Bug 1451097 - make add-ons in-compatible by default for TB 60 and beyond. r=jorgk a=jorgk
mail/app/profile/all-thunderbird.js
--- a/mail/app/profile/all-thunderbird.js
+++ b/mail/app/profile/all-thunderbird.js
@@ -121,18 +121,18 @@ pref("toolkit.crashreporter.infoURL",
 pref("app.support.baseURL", "https://support.live.mozillamessaging.com/%LOCALE%/%APP%/%APPBUILDID%/");
 
 // Show error messages in error console.
 pref("javascript.options.showInConsole", true);
 
 // Controls enabling of the extension system logging (can reduce performance)
 pref("extensions.logging.enabled", false);
 
-// Disables strict compatibility, making addons compatible-by-default.
-pref("extensions.strictCompatibility", false);
+// Strict compatibility makes addons in-compatible by default.
+pref("extensions.strictCompatibility", true);
 
 // Specifies a minimum maxVersion an addon needs to say it's compatible with
 // for it to be compatible by default.
 pref("extensions.minCompatibleAppVersion", "5.0");
 
 pref("extensions.update.autoUpdateDefault", true);
 
 pref("extensions.hotfix.id", "thunderbird-hotfix@mozilla.org");