Bug 1557963 - C-C part: Adapt to array changes of nsIUpdateService.onCheckComplete() and .selectUpdate(). r=bz
authorJorg K <jorgk@jorgk.com>
Sun, 09 Jun 2019 01:06:17 +0200
changeset 35808 d81765c682d0508cf305ed3cccd5c3a033cd46b2
parent 35807 984499e7eacc4e8dbabb68fc4391ea21ad084a36
child 35809 648f20570c30aee87d3746ad7319835d7974d5b8
push id392
push userclokep@gmail.com
push dateMon, 02 Sep 2019 20:17:19 +0000
reviewersbz
bugs1557963
Bug 1557963 - C-C part: Adapt to array changes of nsIUpdateService.onCheckComplete() and .selectUpdate(). r=bz
mail/base/content/aboutDialog-appUpdater.js
--- a/mail/base/content/aboutDialog-appUpdater.js
+++ b/mail/base/content/aboutDialog-appUpdater.js
@@ -266,20 +266,19 @@ appUpdater.prototype = {
    * Implements nsIUpdateCheckListener. The methods implemented by
    * nsIUpdateCheckListener are in a different scope from nsIIncrementalDownload
    * to make it clear which are used by each interface.
    */
   updateCheckListener: {
     /**
      * See nsIUpdateService.idl
      */
-    onCheckComplete(aRequest, aUpdates, aUpdateCount) {
+    onCheckComplete(aRequest, aUpdates) {
       gAppUpdater.isChecking = false;
-      gAppUpdater.update = gAppUpdater.aus.
-                           selectUpdate(aUpdates, aUpdates.length);
+      gAppUpdater.update = gAppUpdater.aus.selectUpdate(aUpdates);
       if (!gAppUpdater.update) {
         gAppUpdater.selectPanel("noUpdatesFound");
         return;
       }
 
       if (gAppUpdater.update.unsupported) {
         let unsupportedLink = document.getElementById("unsupportedLink");
         if (gAppUpdater.update.detailsURL)