Bustage fix for bug 457859 - fix packaging for unofficial branding on OS X Universal builds
authorMark Banner <bugzilla@standard8.plus.com>
Thu, 09 Oct 2008 08:52:06 +0100
changeset 559 f794c3766d9b42f34c6c214bad0efc039d5a4e5e
parent 558 1d810e40645fde2b7e895b556166cd9a3934b1d1
child 560 85b938c0ab7727a5d3ca5e0b02340aba9b4ea0a3
push idunknown
push userunknown
push dateunknown
bugs457859
Bustage fix for bug 457859 - fix packaging for unofficial branding on OS X Universal builds
configure.in
--- a/configure.in
+++ b/configure.in
@@ -7671,17 +7671,17 @@ unset CONFIG_FILES
 # the subdir may not yet have been created in the build tree.
 #
 if test ! -d "mozilla"; then
     mkdir "mozilla"
 fi
 
 # --enable-application needs to find confvars.sh, build.mk, etc in the gived dir, so add ../
 # --disable-official-branding disables all checks for official branding, as we're doing this ourselves in our own repo
-ac_configure_args="$_SUBDIR_CONFIG_ARGS --enable-application=../$MOZ_BUILD_APP --disable-official-branding --with-branding=../$MOZ_BRANDING_DIRECTORY"
+ac_configure_args="$_SUBDIR_CONFIG_ARGS --enable-application=../$MOZ_BUILD_APP --disable-official-branding --with-branding=../$REAL_BRANDING_DIRECTORY"
 if test -z "$MOZ_DEBUG"; then
     ac_configure_args="$ac_configure_args --disable-debug"
 fi
 if test "$MOZ_OPTIMIZE" = "1"; then
     ac_configure_args="$ac_configure_args --enable-optimize"
 fi
 if test -n "$HAVE_64BIT_OS"; then
     ac_configure_args="$ac_configure_args --enable-64bit"