Bug 680236 - raise em:minVersion to not allow Lightning installation in builds that are binary incompatible [r=philipp]
authorStefan Sitter <ssitter@gmail.com>
Tue, 23 Aug 2011 22:41:28 +0200
changeset 8787 e7058e17b135112eeecc0c8ed2b8ff2fcf5f9926
parent 8786 2a3da6d15c356719179a67a6519425cb0fb7b8b2
child 8788 8e731eb1d074f231517f8367aff423d08ed6b2d3
push id158
push userbugzilla@standard8.plus.com
push dateTue, 27 Sep 2011 19:18:14 +0000
treeherdercomm-beta@e47b99c61e4d [default view] [failures only]
perfherder[talos] [build metrics] [platform microbench] (compared to previous push)
reviewersphilipp
bugs680236
Bug 680236 - raise em:minVersion to not allow Lightning installation in builds that are binary incompatible [r=philipp]
calendar/lightning/install.rdf
--- a/calendar/lightning/install.rdf
+++ b/calendar/lightning/install.rdf
@@ -6,26 +6,26 @@
 
   <Description about="urn:mozilla:install-manifest">
     <!-- Target Application this extension can install into,
         with minimum and maximum supported versions. -->
     <em:targetApplication>
       <Description>
         <!-- thunderbird -->
         <em:id>{3550f703-e582-4d05-9a08-453d09bdfdc6}</em:id>
-        <em:minVersion>7.0a1</em:minVersion>
+        <em:minVersion>@THUNDERBIRD_VERSION@</em:minVersion>
         <em:maxVersion>@THUNDERBIRD_VERSION@</em:maxVersion>
       </Description>
     </em:targetApplication>
 
     <em:targetApplication>
       <Description>
         <!-- seamonkey -->
         <em:id>{92650c4d-4b8e-4d2a-b7eb-24ecf4f6b63a}</em:id>
-        <em:minVersion>2.2a1pre</em:minVersion>
+        <em:minVersion>@SEAMONKEY_VERSION@</em:minVersion>
         <em:maxVersion>@SEAMONKEY_VERSION@</em:maxVersion>
       </Description>
     </em:targetApplication>
 
     <em:id>@XPI_EM_ID@</em:id>
     <em:name>Lightning</em:name>
     <em:version>@LIGHTNING_VERSION@</em:version> <!-- BuildID=@GRE_BUILDID@ -->
     <em:description>An integrated calendar for Thunderbird</em:description>