Fix bug 456170 - Cannot change authentication information for GData Provider. r=dbo
authorPhilipp Kewisch <mozilla@kewis.ch>
Mon, 22 Sep 2008 11:31:35 +0200
changeset 394 ba987cfe6d2583450e45b079d0d6060d552827ef
parent 393 09db772e30479b7cd03e3bddaaac5e45ed2402fc
child 395 a993f310afb4eaad1ded44163bbb9dd1f8357ada
push idunknown
push userunknown
push dateunknown
reviewersdbo
bugs456170
Fix bug 456170 - Cannot change authentication information for GData Provider. r=dbo Also increments gdata provider version to 0.6pre
calendar/providers/gdata/components/calGoogleSession.js
calendar/providers/gdata/install.rdf
--- a/calendar/providers/gdata/components/calGoogleSession.js
+++ b/calendar/providers/gdata/components/calGoogleSession.js
@@ -269,17 +269,17 @@ calGoogleSession.prototype = {
                         calendarName);
 
                     // If a different username was entered, switch sessions
 
                     if (aCalendar && username.value != this.mGoogleUser) {
                         var newSession = getGoogleSessionManager()
                                          .getSessionByUsername(username.value,
                                                                true);
-                        newSession.googlePassword = password.value;
+                        newSession.password = password.value;
                         newSession.persist = persist.value;
                         setCalendarPref(aCalendar,
                                         "googleUser",
                                         "CHAR",
                                         username.value);
 
                         // Set the new session for the calendar
                         aCalendar.session = newSession;
--- a/calendar/providers/gdata/install.rdf
+++ b/calendar/providers/gdata/install.rdf
@@ -36,17 +36,17 @@
    -
    - ***** END LICENSE BLOCK ***** -->
 
 <RDF xmlns="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
      xmlns:em="http://www.mozilla.org/2004/em-rdf#">
 
   <Description about="urn:mozilla:install-manifest">
     <em:id>{a62ef8ec-5fdc-40c2-873c-223b8a6925cc}</em:id>
-    <em:version>0.5pre</em:version>
+    <em:version>0.6pre</em:version>
     <em:type>2</em:type>
 
     <!-- Target Application this extension can install into,
          with minimum and maximum supported versions. -->
     <em:targetApplication>
       <Description>
         <!-- sunbird -->
         <em:id>{718e30fb-e89b-41dd-9da7-e25a45638b28}</em:id>