Bug 427750 - Require python >= 2.4 to build Mozilla (and >=2.5 on Windows hosts); (Cv1-CC) Port (the useful part of) it to comm-central.
authorSerge Gautherie <sgautherie.bz@free.fr>
Tue, 16 Feb 2010 05:58:49 +0100
changeset 4914 4e74b1e6e94c4ecc44eafc2fa79e4ca4b1353a66
parent 4913 10bf94ca3428eacea7140401825f6076faee80e7
child 4915 8ed2f205590430903018d614f558d65c46b9a449
push idunknown
push userunknown
push dateunknown
bugs427750
Bug 427750 - Require python >= 2.4 to build Mozilla (and >=2.5 on Windows hosts); (Cv1-CC) Port (the useful part of) it to comm-central. r=Callek.
configure.in
--- a/configure.in
+++ b/configure.in
@@ -853,17 +853,17 @@ AC_MSG_CHECKING([for full perl installat
 _perl_res=$?
 if test "$_perl_res" != 0; then
     AC_MSG_RESULT([no])
     AC_MSG_ERROR([Cannot find Config.pm or \$Config{archlib}.  A full perl installation is required.])
 else
     AC_MSG_RESULT([yes])    
 fi
 
-AC_PATH_PROGS(PYTHON, $PYTHON python)
+AC_PATH_PROGS(PYTHON, $PYTHON python2.5 python2.4 python)
 if test -z "$PYTHON"; then
     AC_MSG_ERROR([python was not found in \$PATH])
 fi
 
 AC_PATH_PROGS(NSINSTALL_BIN, nsinstall )
 if test -z "$COMPILE_ENVIRONMENT"; then
 if test -z "$NSINSTALL_BIN" || test "$NSINSTALL_BIN" = ":"; then
     NSINSTALL_BIN='$(PYTHON) $(MOZILLA_SRCDIR)/config/nsinstall.py'