Bug 509243: MOZ_DEBUG_SYMBOLS=1 fails under WinCE
authornelson%bolyard.com
Sat, 08 Aug 2009 20:43:08 +0000
changeset 4142 2a06d9ff73135cd59a53f04f5e8e72e2f82771c2
parent 4141 d0d80711f78bd77754608383cb38e50a238767a7
child 4143 ee4ed519102eb4df4e8cf8037e5d85be313f737a
push idunknown
push userunknown
push dateunknown
bugs509243
Bug 509243: MOZ_DEBUG_SYMBOLS=1 fails under WinCE Patch contributed by Vladimir Vukicevic <vladimir@pobox.com>, r=nelson
configure
configure.in
--- a/configure
+++ b/configure
@@ -4222,19 +4222,19 @@ EOF
     RESOLVE_LINK_SYMBOLS=1
 
     MDCPUCFG_H=_win95.cfg
     LIBNSPR='$(dist_libdir)/nspr$(MOD_MAJOR_VERSION).$(LIB_SUFFIX)'
     LIBPLC='$(dist_libdir)/plc$(MOD_MAJOR_VERSION).$(LIB_SUFFIX)'
 
     DLLFLAGS='-OUT:"$@"'
     if test -n "$MOZ_DEBUG_SYMBOLS"; then
-        OS_LDFLAGS=-DEBUG -DEBUGTYPE:CV
-        OS_DLLFLAGS=-DEBUG -DEBUGTYPE:CV
-        DSO_LDOPTS=-DEBUG -DEBUGTYPE:CV
+        OS_LDFLAGS='-DEBUG -DEBUGTYPE:CV'
+        OS_DLLFLAGS='-DEBUG -DEBUGTYPE:CV'
+        DSO_LDOPTS='-DEBUG -DEBUGTYPE:CV'
     fi
     _DEBUG_FLAGS=-Zi
     _OPTIMIZE_FLAGS=-O2
     ;;
 
 *-ncr-sysv*)
     cat >> confdefs.h <<\EOF
 #define XP_UNIX 1
--- a/configure.in
+++ b/configure.in
@@ -1674,19 +1674,19 @@ tools are selected during the Xcode/Deve
     RESOLVE_LINK_SYMBOLS=1
 
     MDCPUCFG_H=_win95.cfg
     LIBNSPR='$(dist_libdir)/nspr$(MOD_MAJOR_VERSION).$(LIB_SUFFIX)'
     LIBPLC='$(dist_libdir)/plc$(MOD_MAJOR_VERSION).$(LIB_SUFFIX)'
 
     DLLFLAGS='-OUT:"$@"'
     if test -n "$MOZ_DEBUG_SYMBOLS"; then
-        OS_LDFLAGS=-DEBUG -DEBUGTYPE:CV
-        OS_DLLFLAGS=-DEBUG -DEBUGTYPE:CV
-        DSO_LDOPTS=-DEBUG -DEBUGTYPE:CV
+        OS_LDFLAGS='-DEBUG -DEBUGTYPE:CV'
+        OS_DLLFLAGS='-DEBUG -DEBUGTYPE:CV'
+        DSO_LDOPTS='-DEBUG -DEBUGTYPE:CV'
     fi
     _DEBUG_FLAGS=-Zi
     _OPTIMIZE_FLAGS=-O2
     ;;
 
 *-ncr-sysv*)
     AC_DEFINE(XP_UNIX)
     AC_DEFINE(SVR4)