Bug 517122 - Remove MOZ_DEFAULT_TOOLKIT remnants(!?); (Bv1) Just remove them.
authorSerge Gautherie <sgautherie.bz@free.fr>
Tue, 04 May 2010 17:29:02 +0200
changeset 41770 62baa13553ff648ef411ff4c6d47e929b406ba6a
parent 41769 21d669bd40c52b845c5c5d6c88c82ee8821cf185
child 41771 64b10b53f0ed12bcc2ab522e61944295b659d3dd
push idunknown
push userunknown
push dateunknown
bugs517122
milestone1.9.3a5pre
Bug 517122 - Remove MOZ_DEFAULT_TOOLKIT remnants(!?); (Bv1) Just remove them. r=ted.mielczarek.
configure.in
--- a/configure.in
+++ b/configure.in
@@ -5084,18 +5084,16 @@ MOZ_ARG_HEADER(Toolkit Options)
     then
         dnl nglayout only supports building with one toolkit,
         dnl so ignore everything after the first comma (",").
         MOZ_WIDGET_TOOLKIT=`echo "$_DEFAULT_TOOLKIT" | sed -e "s/,.*$//"`
     else
         AC_MSG_ERROR([You must specify a default toolkit (perhaps $_PLATFORM_DEFAULT_TOOLKIT).])
     fi
 
-AC_DEFINE_UNQUOTED(MOZ_DEFAULT_TOOLKIT,"$MOZ_WIDGET_TOOLKIT")
-
 dnl ========================================================
 dnl = Enable the toolkit as needed                         =
 dnl ========================================================
 
 case "$MOZ_WIDGET_TOOLKIT" in
 photon)
 	MOZ_ENABLE_PHOTON=1
 	AC_DEFINE(MOZ_WIDGET_PHOTON)
@@ -5205,17 +5203,16 @@ if test "$COMPILE_ENVIRONMENT"; then
       GDK_PACKAGES=directfb
     fi
 
     PKG_CHECK_MODULES(MOZ_GTK2, gtk+-2.0 >= $GTK2_VERSION gtk+-unix-print-2.0 glib-2.0 gobject-2.0 $GDK_PACKAGES)
   fi
 
 fi # COMPILE_ENVIRONMENT
 
-AC_SUBST(MOZ_DEFAULT_TOOLKIT)
 AC_SUBST(MOZ_FS_LAYOUT)
 
 dnl ========================================================
 dnl = startup-notification support module
 dnl ========================================================
 
 if test "$MOZ_ENABLE_GTK2"
 then