Bug 1228418 - Upgrade Fennec Gradle configuration to Gradle 2.8 and com.android.tools.build:gradle to 2.0.0-alpha2. r?sebastian draft
authorNick Alexander <nalexander@mozilla.com>
Tue, 01 Dec 2015 15:32:47 -0800
changeset 313198 e3a9ba823b0893b764666ba3f5285d64694c3a23
parent 313197 424d8d1f6b3401275966d7ecf3478d3e46d204e9
child 313199 0cc806aa86311e9f70f1f81b3ddbfb6461d5939d
push id8049
push usernalexander@mozilla.com
push dateWed, 02 Dec 2015 00:55:39 +0000
reviewerssebastian
bugs1228418
milestone45.0a1
Bug 1228418 - Upgrade Fennec Gradle configuration to Gradle 2.8 and com.android.tools.build:gradle to 2.0.0-alpha2. r?sebastian
build.gradle
gradle/wrapper/gradle-wrapper.properties
--- a/build.gradle
+++ b/build.gradle
@@ -27,19 +27,17 @@ buildscript {
         }
         // For spoon SNAPSHOT releases.
         maven {
             url 'https://oss.sonatype.org/content/repositories/snapshots'
         }
     }
 
     dependencies {
-        // Unit testing support was added in 1.1.0. IntelliJ 14.1.4 and Android
-        // Studio 1.2.1.1 appear to work fine with plugin version 1.3.0.
-        classpath 'com.android.tools.build:gradle:1.3.0'
+        classpath 'com.android.tools.build:gradle:2.0.0-alpha2'
         classpath('com.stanfy.spoon:spoon-gradle-plugin:1.0.3-SNAPSHOT') {
             // Without these, we get errors linting.
             exclude module: 'guava'
         }
     }
 }
 
 task generateCodeAndResources(type:Exec) {
--- a/gradle/wrapper/gradle-wrapper.properties
+++ b/gradle/wrapper/gradle-wrapper.properties
@@ -1,6 +1,6 @@
 #Mon Nov 02 13:44:39 GMT 2015
 distributionBase=GRADLE_USER_HOME
 distributionPath=wrapper/dists
 zipStoreBase=GRADLE_USER_HOME
 zipStorePath=wrapper/dists
-distributionUrl=https\://services.gradle.org/distributions/gradle-2.7-all.zip
+distributionUrl=https\://services.gradle.org/distributions/gradle-2.8-all.zip