Bug 1126017 - Use --enable-warnings-as-errors on Win64 builders. r=glandium
☠☠ backed out by 5d8e34d06f43 ☠ ☠
authorMasatoshi Kimura <VYV03354@nifty.ne.jp>
Tue, 27 Jan 2015 20:46:27 +0900
changeset 239388 c3c8794b37bf9bf63561d1451a4921b873857435
parent 239387 01644d704dcf67f726de302b699d33cd06390c98
child 239389 5d8e34d06f43735d7824da716e176cc391eadda3
push id497
push usermleibovic@mozilla.com
push dateWed, 28 Jan 2015 16:43:37 +0000
reviewersglandium
bugs1126017
milestone38.0a1
Bug 1126017 - Use --enable-warnings-as-errors on Win64 builders. r=glandium
browser/config/mozconfigs/win64/common-opt
browser/config/mozconfigs/win64/debug
--- a/browser/config/mozconfigs/win64/common-opt
+++ b/browser/config/mozconfigs/win64/common-opt
@@ -20,10 +20,13 @@ fi
 ac_add_options --with-google-oauth-api-keyfile=${_google_oauth_api_keyfile}
 ac_add_options --with-mozilla-api-keyfile=/c/builds/mozilla-desktop-geoloc-api.key
 
 # Needed to enable breakpad in application.ini
 export MOZILLA_OFFICIAL=1
 
 export MOZ_TELEMETRY_REPORTING=1
 
+# Treat warnings as errors in directories with FAIL_ON_WARNINGS.
+ac_add_options --enable-warnings-as-errors
+
 # Package js shell.
 export MOZ_PACKAGE_JSSHELL=1
--- a/browser/config/mozconfigs/win64/debug
+++ b/browser/config/mozconfigs/win64/debug
@@ -15,14 +15,17 @@ if [ -f /c/builds/google-oauth-api.key ]
 else
   _google_oauth_api_keyfile=/e/builds/google-oauth-api.key
 fi
 ac_add_options --with-google-oauth-api-keyfile=${_google_oauth_api_keyfile}
 
 # Needed to enable breakpad in application.ini
 export MOZILLA_OFFICIAL=1
 
+# Treat warnings as errors in directories with FAIL_ON_WARNINGS.
+ac_add_options --enable-warnings-as-errors
+
 # Package js shell.
 export MOZ_PACKAGE_JSSHELL=1
 
 . $topsrcdir/build/win64/mozconfig.vs2013
 
 . "$topsrcdir/build/mozconfig.common.override"