Bug 1292696 - Remove version checks for libxcb and libgl; r=ahal
authorGregory Szorc <gps@mozilla.com>
Mon, 08 Aug 2016 14:42:06 -0700
changeset 398790 5746ddb617c4420846a2e8de243a917b1aea8028
parent 398789 b47abe0917b074d95b7e240a8deda72bf4a71b84
child 398791 338addbf100c98350099d3a13b6621d9294159a8
push id25628
push userbmo:gps@mozilla.com
push dateTue, 09 Aug 2016 18:38:55 +0000
reviewersahal
bugs1292696
milestone51.0a1
Bug 1292696 - Remove version checks for libxcb and libgl; r=ahal Pinning these packages breaks Ubuntu package management because other packages we install explicitly require a newer version. Attempting to pin these results in packages getting removed or refusal to install. MozReview-Commit-ID: AhQbjavCKI1
testing/docker/ubuntu1604-test/system-setup.sh
--- a/testing/docker/ubuntu1604-test/system-setup.sh
+++ b/testing/docker/ubuntu1604-test/system-setup.sh
@@ -157,26 +157,21 @@ apt-get update
 apt-get -q -y -f install ubuntu-restricted-extras
 
 apt-get -q -y -f install \
     libxcb1 \
     libxcb-render0 \
     libxcb-shm0 \
     libxcb-glx0 \
     libxcb-shape0
-libxcb1_version=$(dpkg-query -s libxcb1 | grep ^Version | awk '{ print $2 }')
-[ "$libxcb1_version" = "1.11.1-1ubuntu1" ] || exit 1
 
 apt-get -q -y -f install \
     libgl1-mesa-dri \
     libgl1-mesa-glx \
     mesa-common-dev
-mesa_version=$(dpkg-query -s libgl1-mesa-dri | grep ^Version | awk '{ print $2 }')
-echo $mesa_version
-[ "$mesa_version" = "11.2.0-1ubuntu2" ] || exit 1
 
 # revert the list of repos
 cp sources.list.orig /etc/apt/sources.list
 apt-get update
 
 # clean up
 cd /
 rm -rf /setup ~/.ccache ~/.cache ~/.npm