Bug 902617 - Make mach bootstrap warn about possibly outdated Xcode when Xcode command line tools are outdated. r=gps
authorDrew Willcoxon <adw@mozilla.com>
Fri, 09 Aug 2013 16:57:40 -0700
changeset 142141 1bdd3f639d69f139ed670ae424f322c8f00298e5
parent 142140 0c2ce8aaa005341e3f2bedfb9849a44df8590b2c
child 142142 ab48e2538553a1cb08a4c3acbd5fb6d9839900a8
push id1
push userroot
push dateMon, 20 Oct 2014 17:29:22 +0000
reviewersgps
bugs902617
milestone26.0a1
Bug 902617 - Make mach bootstrap warn about possibly outdated Xcode when Xcode command line tools are outdated. r=gps
python/mozboot/mozboot/osx.py
--- a/python/mozboot/mozboot/osx.py
+++ b/python/mozboot/mozboot/osx.py
@@ -57,17 +57,20 @@ Perform the following steps to install t
     4) Go to the Download tab (near the right)
     5) Install the "Command Line Tools"
 
 When that has finished installing, please relaunch this script.
 '''
 
 UPGRADE_XCODE_COMMAND_LINE_TOOLS = '''
 An old version of the Xcode command line tools is installed. You will need to
-install a newer version in order to compile Firefox.
+install a newer version in order to compile Firefox. If Xcode itself is old,
+its command line tools may be too old even if it claims there are no updates
+available, so if you are seeing this message multiple times, please update
+Xcode first.
 '''
 
 PACKAGE_MANAGER_INSTALL = '''
 We will install the %s package manager to install required packages.
 
 You will be prompted to install %s with its default settings. If you
 would prefer to do this manually, hit CTRL+c, install %s yourself, ensure
 "%s" is in your $PATH, and relaunch bootstrap.