Bug 1406669 - Add the .configure extension to flake8 support r=ahal
authorSylvestre Ledru <sledru@mozilla.com>
Wed, 11 Oct 2017 16:03:32 +0200
changeset 679094 0648d35fc2d89d4aeb1352fcfb41e51db1b4a434
parent 679093 9267711b1ddfef1a88f518983933ba3a6779e6bf
child 679095 063607e625874aac87a95e57e0846b44dc29ec77
push id84141
push userbmo:schien@mozilla.com
push dateThu, 12 Oct 2017 11:13:04 +0000
reviewersahal
bugs1406669
milestone58.0a1
Bug 1406669 - Add the .configure extension to flake8 support r=ahal MozReview-Commit-ID: ErnYnQMv5pj
tools/lint/flake8.yml
--- a/tools/lint/flake8.yml
+++ b/tools/lint/flake8.yml
@@ -24,11 +24,12 @@ flake8:
         - tools/git
         - tools/lint
         - tools/mercurial
         - tools/tryselect
         - toolkit/components/telemetry
     # Excludes should be added to topsrcdir/.flake8 due to a bug in flake8 where
     # specifying --exclude causes custom configuration files to be ignored.
     exclude: []
-    extensions: ['py']
+    # The configure option is used by the build system
+    extensions: ['configure', 'py']
     type: external
     payload: python.flake8:lint