accessible/atk/DocAccessibleWrap.cpp
author Gregory Szorc <gps@mozilla.com>
Wed, 20 Jul 2016 09:21:38 -0700
changeset 390086 5fa517a2ac0dd948a2826c7031ee3784f528b40a
parent 336209 2449cf975cde24c9b4ecfe3fd3a0560e8405c348
child 489668 cbb8fdf1daf98a15f7d57f6b08d273bdf96aa1a0
child 648192 c236dfe7dc98c387219d7cb45d0693560db708fd
child 693329 78f6394c884cc4d87c5ac188ba4abeec314813a4
child 694109 98e2b4ee9775a2a2b5cc1bb8a390bfe901814f38
permissions -rw-r--r--
Bug 1247168 - Change decision image to Ubuntu 16.04; r?dustin We're currently running Ubuntu 14.04 in the decision image. While still in LTS support, 16.04 ships with a modern, properly configured Python 2.7. So we upgrade to 16.04 and drop the install of Python from source because it is no longer needed. This is part 1 of a larger refactor to this image.

/* -*- Mode: C++; tab-width: 2; indent-tabs-mode: nil; c-basic-offset: 2 -*- */
/* vim: set ts=2 et sw=2 tw=80: */
/* This Source Code Form is subject to the terms of the Mozilla Public
 * License, v. 2.0. If a copy of the MPL was not distributed with this
 * file, You can obtain one at http://mozilla.org/MPL/2.0/. */

#include "nsMai.h"
#include "DocAccessibleWrap.h"

using namespace mozilla::a11y;

////////////////////////////////////////////////////////////////////////////////
// DocAccessibleWrap
////////////////////////////////////////////////////////////////////////////////

DocAccessibleWrap::
  DocAccessibleWrap(nsIDocument* aDocument, nsIPresShell* aPresShell) :
  DocAccessible(aDocument, aPresShell), mActivated(false)
{
}

DocAccessibleWrap::~DocAccessibleWrap()
{
}