Bug 1366542 - Bump required version of Rust to 1.17.0. r=mshal
authorXidorn Quan <me@upsuper.org>
Sun, 21 May 2017 11:48:33 +1000
changeset 360106 f4d2f782dcdaa2aa6fbf10c4733b08ebe9bca709
parent 360105 b1daab599fecafbadad7377f0ded446dd6ad7559
child 360107 c0a31caeaad86985c5dc23d84f9d0a188c484650
push id31868
push userryanvm@gmail.com
push dateTue, 23 May 2017 14:32:52 +0000
treeherdermozilla-central@3a82a745123f [default view] [failures only]
perfherder[talos] [build metrics] [platform microbench] (compared to previous push)
reviewersmshal
bugs1366542
milestone55.0a1
first release with
nightly linux32
nightly linux64
nightly mac
nightly win32
nightly win64
last release without
nightly linux32
nightly linux64
nightly mac
nightly win32
nightly win64
Bug 1366542 - Bump required version of Rust to 1.17.0. r=mshal MozReview-Commit-ID: Bgz6etF2vR2
python/mozboot/mozboot/base.py
--- a/python/mozboot/mozboot/base.py
+++ b/python/mozboot/mozboot/base.py
@@ -157,17 +157,17 @@ ac_add_options --enable-artifact-builds
 # This should match OLDEST_NON_LEGACY_VERSION from
 # the hg setup wizard in version-control-tools.
 MODERN_MERCURIAL_VERSION = LooseVersion('3.7.3')
 
 # Upgrade Python older than this.
 MODERN_PYTHON_VERSION = LooseVersion('2.7.3')
 
 # Upgrade rust older than this.
-MODERN_RUST_VERSION = LooseVersion('1.15.1')
+MODERN_RUST_VERSION = LooseVersion('1.17.0')
 
 class BaseBootstrapper(object):
     """Base class for system bootstrappers."""
 
     def __init__(self, no_interactive=False):
         self.package_manager_updated = False
         self.no_interactive = no_interactive
         self.stylo = False