Bug 1322792 - require GCC 4.9 to build; r=glandium
authorNathan Froyd <froydnj@mozilla.com>
Fri, 23 Dec 2016 05:47:31 -0500
changeset 327213 ba473bab31981a12e25e508bf1dce3a36d9f7bab
parent 327212 fd069b26630ca44b36769aeb72320f45cece4676
child 327214 8ed792a02180b9ead5b85b3d9983319dfe67d891
push id31122
push userphilringnalda@gmail.com
push dateSun, 25 Dec 2016 00:51:37 +0000
treeherdermozilla-central@1156db49e976 [default view] [failures only]
perfherder[talos] [build metrics] [platform microbench] (compared to previous push)
reviewersglandium
bugs1322792
milestone53.0a1
first release with
nightly linux32
nightly linux64
nightly mac
nightly win32
nightly win64
last release without
nightly linux32
nightly linux64
nightly mac
nightly win32
nightly win64
Bug 1322792 - require GCC 4.9 to build; r=glandium
build/moz.configure/toolchain.configure
mfbt/Compiler.h
python/mozbuild/mozbuild/test/configure/test_toolchain_configure.py
--- a/build/moz.configure/toolchain.configure
+++ b/build/moz.configure/toolchain.configure
@@ -697,19 +697,19 @@ def compiler(language, host_or_target, c
             raise FatalCheckError(
                 'Unknown compiler or compiler not supported.')
 
         # Compiler version checks
         # ===================================================
         # Check the compiler version here instead of in `compiler_version` so
         # that the `checking` message doesn't pretend the compiler can be used
         # to then bail out one line later.
-        if info.type == 'gcc' and info.version < '4.8.0':
+        if info.type == 'gcc' and info.version < '4.9.0':
             raise FatalCheckError(
-                'Only GCC 4.8 or newer is supported (found version %s).'
+                'Only GCC 4.9 or newer is supported (found version %s).'
                 % info.version)
 
         # If you want to bump the version check here search for
         # __cpp_static_assert above, and see the associated comment.
         if info.type == 'clang' and not info.version:
             raise FatalCheckError(
                 'Only clang/llvm 3.6 or newer is supported.')
 
--- a/mfbt/Compiler.h
+++ b/mfbt/Compiler.h
@@ -21,18 +21,18 @@
     * for gcc 4.7.1 or later, check `#if MOZ_GCC_VERSION_AT_LEAST(4, 7, 1)`.
     */
 #  define MOZ_GCC_VERSION_AT_LEAST(major, minor, patchlevel)          \
      ((__GNUC__ * 10000 + __GNUC_MINOR__ * 100 + __GNUC_PATCHLEVEL__) \
       >= ((major) * 10000 + (minor) * 100 + (patchlevel)))
 #  define MOZ_GCC_VERSION_AT_MOST(major, minor, patchlevel)           \
      ((__GNUC__ * 10000 + __GNUC_MINOR__ * 100 + __GNUC_PATCHLEVEL__) \
       <= ((major) * 10000 + (minor) * 100 + (patchlevel)))
-#  if !MOZ_GCC_VERSION_AT_LEAST(4, 8, 0)
-#    error "mfbt (and Gecko) require at least gcc 4.8 to build."
+#  if !MOZ_GCC_VERSION_AT_LEAST(4, 9, 0)
+#    error "mfbt (and Gecko) require at least gcc 4.9 to build."
 #  endif
 
 #elif defined(_MSC_VER)
 
 #  undef MOZ_IS_MSVC
 #  define MOZ_IS_MSVC 1
 
 #endif
--- a/python/mozbuild/mozbuild/test/configure/test_toolchain_configure.py
+++ b/python/mozbuild/mozbuild/test/configure/test_toolchain_configure.py
@@ -308,17 +308,17 @@ class LinuxToolchainTest(BaseToolchainTe
         '/usr/bin/g++-5': GXX_5 + GCC_PLATFORM_X86_64_LINUX,
         '/usr/bin/clang': CLANG_3_6 + CLANG_PLATFORM_X86_64_LINUX,
         '/usr/bin/clang++': CLANGXX_3_6 + CLANG_PLATFORM_X86_64_LINUX,
         '/usr/bin/clang-3.6': CLANG_3_6 + CLANG_PLATFORM_X86_64_LINUX,
         '/usr/bin/clang++-3.6': CLANGXX_3_6 + CLANG_PLATFORM_X86_64_LINUX,
         '/usr/bin/clang-3.3': CLANG_3_3 + CLANG_PLATFORM_X86_64_LINUX,
         '/usr/bin/clang++-3.3': CLANGXX_3_3 + CLANG_PLATFORM_X86_64_LINUX,
     }
-    GCC_4_7_RESULT = ('Only GCC 4.8 or newer is supported '
+    GCC_4_7_RESULT = ('Only GCC 4.9 or newer is supported '
                       '(found version 4.7.3).')
     GXX_4_7_RESULT = GCC_4_7_RESULT
     GCC_4_9_RESULT = CompilerResult(
         flags=['-std=gnu99'],
         version='4.9.3',
         type='gcc',
         compiler='/usr/bin/gcc',
         language='C',