Bug 1727507 - Migrate Windows 10 mochitest-chrome from AWS to Azure r=jmaher
authorMichelle Goossens <michelle@masterwayz.nl>
Wed, 25 Aug 2021 14:41:15 +0000
changeset 589906 b2b205bcb224d180a18688dc932b9f89cd0a4913
parent 589905 9b84935e7a648cf20e3c560df7231be542728133
child 589907 eb76844d30c2a2487d4696c1fedabb97b2c6d3f5
push id38736
push userabutkovits@mozilla.com
push dateWed, 25 Aug 2021 21:49:19 +0000
treeherdermozilla-central@6c984a259bdc [default view] [failures only]
perfherder[talos] [build metrics] [platform microbench] (compared to previous push)
reviewersjmaher
bugs1727507
milestone93.0a1
first release with
nightly linux32
nightly linux64
nightly mac
nightly win32
nightly win64
last release without
nightly linux32
nightly linux64
nightly mac
nightly win32
nightly win64
Bug 1727507 - Migrate Windows 10 mochitest-chrome from AWS to Azure r=jmaher Differential Revision: https://phabricator.services.mozilla.com/D123606
taskcluster/ci/test/test-sets.yml
toolkit/content/tests/chrome/chrome.ini
--- a/taskcluster/ci/test/test-sets.yml
+++ b/taskcluster/ci/test/test-sets.yml
@@ -225,17 +225,16 @@ windows32-tests:
     - test-verify-gpu
     - test-verify-wpt
 
 windows-tests:
     - firefox-ui-functional-local
     - firefox-ui-functional-remote
     # - jittest  # See comment in windows-ccov-tests set.
     - marionette
-    - mochitest-chrome
     - telemetry-tests-client
 
 windows-ccov-tests:
     # jittest run on regular windows builds is redundant with SM(p), so we omit
     # it from the windows-tests set. But, we still want to run it on ccov builds,
     # so we have this set that has it and which runs on ccov builds.
     - jittest
 
@@ -244,16 +243,17 @@ windows10-tests:
 
 windows10-2004-tests:
     - cppunit
     - crashtest
     - gtest
     - jsreftest
     - mochitest-a11y
     - mochitest-browser-chrome
+    - mochitest-chrome
     - mochitest-chrome-gpu
     - mochitest-devtools-chrome
     - mochitest-media
     - mochitest-plain
     - mochitest-plain-gpu
     - mochitest-remote
     - mochitest-webgpu
     - mochitest-webgl1-ext
--- a/toolkit/content/tests/chrome/chrome.ini
+++ b/toolkit/content/tests/chrome/chrome.ini
@@ -53,17 +53,19 @@ support-files =
   rtlchrome/rtl.dtd
   rtlchrome/rtl.manifest
 prefs =
   gfx.font_rendering.fallback.async=false
   widget.non-native-theme.enabled=false
 
 [test_about_networking.html]
 [test_arrowpanel.xhtml]
-skip-if = (verify && (os == 'win')) || (debug && (os == 'win') && (bits == 32)) # Bug 1546256
+skip-if =
+  (verify && (os == 'win')) || (debug && (os == 'win') && (bits == 32)) # Bug 1546256
+  win10_2004 # Bug 1727507
 [test_autocomplete2.xhtml]
 [test_autocomplete3.xhtml]
 [test_autocomplete4.xhtml]
 [test_autocomplete5.xhtml]
 [test_autocomplete_emphasis.xhtml]
 [test_autocomplete_with_composition_on_input.html]
 [test_autocomplete_placehold_last_complete.xhtml]
 [test_browser_drop.xhtml]