Bug 1583770 - Allow access to pref network.auth.force-generic-ntlm-v1 off the main tread. r=njn
authorJorg K <jorgk@jorgk.com>
Fri, 11 Oct 2019 03:26:15 +0300
changeset 497204 94ab8abd4d3a1be6568b84cc9eb93a12b514c4f3
parent 497203 960a7e198846fecdfe46663bd04e1480e46f2399
child 497205 f15fe0194c52f28cb6dabde3088f3e9711c3bd14
push id36679
push userdluca@mozilla.com
push dateFri, 11 Oct 2019 09:30:10 +0000
treeherdermozilla-central@a7ca5ad33f3d [default view] [failures only]
perfherder[talos] [build metrics] [platform microbench] (compared to previous push)
reviewersnjn
bugs1583770
milestone71.0a1
first release with
nightly linux32
nightly linux64
nightly mac
nightly win32
nightly win64
last release without
nightly linux32
nightly linux64
nightly mac
nightly win32
nightly win64
Bug 1583770 - Allow access to pref network.auth.force-generic-ntlm-v1 off the main tread. r=njn
modules/libpref/init/StaticPrefList.yaml
--- a/modules/libpref/init/StaticPrefList.yaml
+++ b/modules/libpref/init/StaticPrefList.yaml
@@ -6282,17 +6282,17 @@
   mirror: always
 
 #---------------------------------------------------------------------------
 # Prefs starting with "network."
 #---------------------------------------------------------------------------
 
 # Force less-secure NTLMv1 when needed (NTLMv2 is the default).
 - name: network.auth.force-generic-ntlm-v1
-  type: bool
+  type: RelaxedAtomicBool
   value: false
   mirror: always
 
 # Sub-resources HTTP-authentication:
 #   0 - don't allow sub-resources to open HTTP authentication credentials
 #       dialogs
 #   1 - allow sub-resources to open HTTP authentication credentials dialogs,
 #       but don't allow it for cross-origin sub-resources