Bug 1503455 - Part 2: Remove compile SDK setting from configure. r=nalexander
authorJan Henning <jh+bugzilla@buttercookie.de>
Mon, 28 Jan 2019 18:31:57 +0000
changeset 455696 8a0f54126a96e3d388768df175a3aef59f321d6b
parent 455695 df118467fa9ac78a416cf4d1dc551fd5997813fc
child 455697 b25a6a0433d62d03c6a03d7b725a95007655800f
push id35457
push usercsabou@mozilla.com
push dateTue, 29 Jan 2019 09:20:40 +0000
treeherdermozilla-central@84104c5031c3 [default view] [failures only]
perfherder[talos] [build metrics] [platform microbench] (compared to previous push)
reviewersnalexander
bugs1503455, 1498406
milestone66.0a1
first release with
nightly linux32
nightly linux64
nightly mac
nightly win32
nightly win64
last release without
nightly linux32
nightly linux64
nightly mac
nightly win32
nightly win64
Bug 1503455 - Part 2: Remove compile SDK setting from configure. r=nalexander Post bug 1498406, this seems to be unused and doesn't affect anything. Differential Revision: https://phabricator.services.mozilla.com/D16420
build/autoconf/android.m4
old-configure.in
--- a/build/autoconf/android.m4
+++ b/build/autoconf/android.m4
@@ -86,19 +86,18 @@ if test "$OS_TARGET" = "Android"; then
     fi
 fi
 AC_SUBST_LIST([STLPORT_LIBS])
 
 ])
 
 
 dnl Configure an Android SDK.
-dnl Arg 1: compile SDK version, like 23.
-dnl Arg 2: target SDK version, like 23.
-dnl Arg 3: list of build-tools versions, like "23.0.3 23.0.1".
+dnl Arg 1: target SDK version, like 23.
+dnl Arg 2: list of build-tools versions, like "23.0.3 23.0.1".
 AC_DEFUN([MOZ_ANDROID_SDK],
 [
 
 MOZ_ARG_WITH_STRING(android-sdk,
 [  --with-android-sdk=DIR
                           location where the Android SDK can be found (like ~/.mozbuild/android-sdk-linux)],
     android_sdk_root=$withval)
 
@@ -112,21 +111,21 @@ case "$target" in
 
     # We were given an old-style
     # --with-android-sdk=/path/to/sdk/platforms/android-*.  We could warn, but
     # we'll get compliance by forcing the issue.
     if test -e "$withval"/source.properties ; then
         AC_MSG_ERROR([Including platforms/android-* in --with-android-sdk arguments is deprecated.  Use --with-android-sdk=$android_sdk_root.])
     fi
 
-    android_target_sdk=$2
+    android_target_sdk=$1
 
     AC_MSG_CHECKING([for Android build-tools])
     android_build_tools_base="$android_sdk_root"/build-tools
-    for version in $3; do
+    for version in $2; do
         android_build_tools="$android_build_tools_base"/$version
         if test -d "$android_build_tools" -a -f "$android_build_tools/zipalign"; then
             AC_MSG_RESULT([$android_build_tools])
             break
         fi
     done
 
     MOZ_PATH_PROG(ZIPALIGN, zipalign, :, [$android_build_tools])
--- a/old-configure.in
+++ b/old-configure.in
@@ -1830,17 +1830,17 @@ AC_SUBST(MOZ_XULRUNNER)
 
 dnl ========================================================
 dnl Ensure Android SDK and build-tools versions depending on
 dnl mobile target.
 dnl ========================================================
 
 case "$MOZ_BUILD_APP" in
 mobile/android)
-    MOZ_ANDROID_SDK(26, 26, 27.0.3)
+    MOZ_ANDROID_SDK(26, 27.0.3)
     ;;
 esac
 
 dnl ========================================================
 dnl =
 dnl = Toolkit Options
 dnl =
 dnl ========================================================