Bug 1408567 - Require Rust 1.20.0 or newer. r=nalexander
authorRalph Giles <giles@mozilla.com>
Fri, 13 Oct 2017 15:08:21 -0700
changeset 386277 8879a995468d8e5e02608c9d25c2319307be0133
parent 386276 dc8e472c99d982e81864ac6d419930fa26dabcd1
child 386278 2a9fc9a1825be8787184d344c26f30d3a61513eb
push id32686
push userarchaeopteryx@coole-files.de
push dateSun, 15 Oct 2017 09:40:59 +0000
treeherdermozilla-central@0bd9b61304e2 [default view] [failures only]
perfherder[talos] [build metrics] [platform microbench] (compared to previous push)
reviewersnalexander
bugs1408567, 1396884
milestone58.0a1
first release with
nightly linux32
nightly linux64
nightly mac
nightly win32
nightly win64
last release without
nightly linux32
nightly linux64
nightly mac
nightly win32
nightly win64
Bug 1408567 - Require Rust 1.20.0 or newer. r=nalexander By the schedule we would have bumped the minimum-supported rust version to 1.20.0 some weeks ago, just before Firefox 57 went to beta. However, that was blocked on a couple of compatibility issues with sccache and dsymutil. See bug 1396884. Now that 1.20.0 is working in our automation builds, require it for all builds to unblock servo and webrender upgrades. Also update our integration test to verify building with the new minimum. MozReview-Commit-ID: 8otdix6f45f
build/moz.configure/rust.configure
taskcluster/ci/build/linux.yml
--- a/build/moz.configure/rust.configure
+++ b/build/moz.configure/rust.configure
@@ -53,17 +53,17 @@ def rust_compiler(rustc_info, cargo_info
         die(dedent('''\
         Rust compiler not found.
         To compile rust language sources, you must have 'rustc' in your path.
         See https://www.rust-lang.org/ for more information.
 
         You can install rust by running './mach bootstrap'
         or by directly running the installer from https://rustup.rs/
         '''))
-    rustc_min_version = Version('1.19.0')
+    rustc_min_version = Version('1.20.0')
     cargo_min_version = Version('0.{}'.format(rustc_min_version.minor + 1))
 
     version = rustc_info.version
     if version < rustc_min_version:
         die(dedent('''\
         Rust compiler {} is too old.
 
         To compile Rust language sources please install at least
--- a/taskcluster/ci/build/linux.yml
+++ b/taskcluster/ci/build/linux.yml
@@ -175,17 +175,17 @@ linux64-base-toolchains/opt:
             - balrog/production.py
         script: "mozharness/scripts/fx_desktop_build.py"
         secrets: true
         tooltool-downloads: public
         need-xvfb: true
     toolchains:
         - linux64-clang-3.9
         - linux64-gcc-4.9
-        - linux64-rust-1.19
+        - linux64-rust-1.20
         - linux64-sccache
 
 linux64-base-toolchains/debug:
     description: "Linux64 base toolchains Debug"
     index:
         product: firefox
         job-name: linux64-base-toolchains-debug
     treeherder:
@@ -206,17 +206,17 @@ linux64-base-toolchains/debug:
         script: "mozharness/scripts/fx_desktop_build.py"
         secrets: true
         custom-build-variant-cfg: debug
         tooltool-downloads: public
         need-xvfb: true
     toolchains:
         - linux64-clang-3.9
         - linux64-gcc-4.9
-        - linux64-rust-1.19
+        - linux64-rust-1.20
         - linux64-sccache
 
 linux/opt:
     description: "Linux32 Opt"
     index:
         product: firefox
         job-name: linux-opt
     treeherder: