Bug 1600404 [wpt PR 20543] - Update wpt metadata, a=testonly
authormoz-wptsync-bot <wptsync@mozilla.com>
Mon, 04 May 2020 23:47:08 +0000
changeset 530991 7d9f2163cc1fb356d9a8ad26ddb1943da3653984
parent 530990 22a8ec0f49cab621212d7dcb69cd38129f0979ba
child 530992 9e284d177f1b44043a8c65233f4e039f6f703f01
push id37435
push userapavel@mozilla.com
push dateWed, 20 May 2020 15:28:23 +0000
treeherdermozilla-central@5415da14ec9a [default view] [failures only]
perfherder[talos] [build metrics] [platform microbench] (compared to previous push)
reviewerstestonly
bugs1600404, 20543
milestone78.0a1
first release with
nightly linux32
nightly linux64
nightly mac
nightly win32
nightly win64
last release without
nightly linux32
nightly linux64
nightly mac
nightly win32
nightly win64
Bug 1600404 [wpt PR 20543] - Update wpt metadata, a=testonly wpt-pr: 20543 wpt-type: metadata
testing/web-platform/meta/css/css-flexbox/select-element-zero-height-001.html.ini
testing/web-platform/meta/css/css-scroll-snap/input/keyboard.html.ini
testing/web-platform/meta/css/css-ui/appearance-textfield-001.html.ini
testing/web-platform/meta/encoding/textdecoder-copy.any.js.ini
testing/web-platform/meta/fetch/api/abort/general.any.js.ini
testing/web-platform/meta/html/browsers/the-window-object/apis-for-creating-and-navigating-browsing-contexts-by-name/open-features-tokenization-width-height.html.ini
testing/web-platform/meta/html/browsers/windows/auxiliary-browsing-contexts/opener-setter.html.ini
testing/web-platform/meta/html/cross-origin-opener-policy/coop-sandbox.https.html.ini
testing/web-platform/meta/html/cross-origin-opener-policy/iframe-popup-same-origin-allow-popups-to-same-origin-allow-popups.https.html.ini
testing/web-platform/meta/html/cross-origin-opener-policy/popup-same-origin-with-same-site.https.html.ini
testing/web-platform/meta/html/interaction/focus/the-autofocus-attribute/first-when-later.html.ini
testing/web-platform/meta/html/interaction/focus/the-autofocus-attribute/no-autofocus-on-changing-input-type.html.ini
testing/web-platform/meta/html/interaction/focus/the-autofocus-attribute/queue-non-focusable.html.ini
testing/web-platform/meta/html/semantics/forms/constraints/form-validation-reportValidity.html.ini
testing/web-platform/meta/inert/inert-retargeting-iframe.tentative.html.ini
testing/web-platform/meta/mediacapture-streams/historical.https.html.ini
testing/web-platform/meta/referrer-policy/css-integration/svg/processing-instruction.html.ini
testing/web-platform/meta/resource-timing/resource-timing-level1.sub.html.ini
testing/web-platform/meta/svg/text/reftests/dominant-baseline-hanging-small-font-size.svg.ini
testing/web-platform/meta/webaudio/the-audio-api/the-convolvernode-interface/convolution-mono-mono.html.ini
testing/web-platform/meta/webaudio/the-audio-api/the-convolvernode-interface/convolver-upmixing-1-channel-response.html.ini
testing/web-platform/meta/webrtc/RTCDTMFSender-ontonechange-long.https.html.ini
testing/web-platform/meta/webrtc/RTCPeerConnection-createDataChannel.html.ini
testing/web-platform/meta/webrtc/RTCPeerConnection-ondatachannel.html.ini
testing/web-platform/meta/webrtc/RTCPeerConnection-operations.https.html.ini
testing/web-platform/meta/webrtc/RTCPeerConnection-setRemoteDescription-offer.html.ini
testing/web-platform/meta/webrtc/RTCRtpReceiver-getStats.https.html.ini
--- a/testing/web-platform/meta/css/css-flexbox/select-element-zero-height-001.html.ini
+++ b/testing/web-platform/meta/css/css-flexbox/select-element-zero-height-001.html.ini
@@ -1,5 +1,5 @@
 [select-element-zero-height-001.html]
   bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1596255
   expected:
-    if os == "mac": ["FAIL", "PASS"]
+    if os == "mac": [FAIL, PASS]
     [PASS, FAIL]
--- a/testing/web-platform/meta/css/css-scroll-snap/input/keyboard.html.ini
+++ b/testing/web-platform/meta/css/css-scroll-snap/input/keyboard.html.ini
@@ -8,11 +8,11 @@
   [Snaps to top-left after pressing ArrowUp]
     expected: FAIL
 
   [Snaps to top-left after pressing ArrowLeft]
     expected: FAIL
 
   [Snaps to top-right after pressing ArrowRight]
     expected:
-      if (os == "linux") and debug and webrender and not fission: ["PASS", "FAIL"]
-      if os == "mac": ["PASS", "FAIL"]
+      if (os == "linux") and debug and webrender and not fission: [PASS, FAIL]
+      if os == "mac": [PASS, FAIL]
 
--- a/testing/web-platform/meta/css/css-ui/appearance-textfield-001.html.ini
+++ b/testing/web-platform/meta/css/css-ui/appearance-textfield-001.html.ini
@@ -1,6 +1,10 @@
 [appearance-textfield-001.html]
   fuzzy:
     if os == "android": maxDifference=0-1;totalPixels=0-23
   expected:
-    if (os == "win") and fission: ["FAIL", "PASS"]
-    if (os == "win") and not fission: ["FAIL", "PASS"]
+    if (os == "win") and fission: [FAIL, PASS]
+    if (os == "win") and (processor == "x86_64") and debug and not webrender: [PASS, FAIL]
+    if (os == "win") and (processor == "x86_64") and debug and webrender: [FAIL, PASS]
+    if (os == "win") and (processor == "x86_64") and not debug and webrender: [FAIL, PASS]
+    if (os == "win") and (processor == "x86_64") and not debug and not webrender: [FAIL, PASS]
+    if (os == "win") and (processor == "x86"): [FAIL, PASS]
--- a/testing/web-platform/meta/encoding/textdecoder-copy.any.js.ini
+++ b/testing/web-platform/meta/encoding/textdecoder-copy.any.js.ini
@@ -9,11 +9,13 @@
 
 
 [textdecoder-copy.any.sharedworker.html]
   [Modify buffer after passing it in (SharedArrayBuffer)]
     expected: FAIL
 
 
 [textdecoder-copy.any.serviceworker.html]
+  expected:
+    if not early_beta_or_earlier: ERROR
   [Modify buffer after passing it in (SharedArrayBuffer)]
     expected: FAIL
 
--- a/testing/web-platform/meta/fetch/api/abort/general.any.js.ini
+++ b/testing/web-platform/meta/fetch/api/abort/general.any.js.ini
@@ -1,29 +1,36 @@
 [general.any.worker.html]
   [Stream will not error if body is empty. It's closed with an empty queue before it errors.]
     expected: FAIL
 
   [Readable stream synchronously cancels with AbortError if aborted before reading]
     expected: FAIL
 
+  [Stream errors once aborted. Underlying connection closed.]
+    expected:
+      if (os == "linux") and not debug and webrender: [PASS, FAIL]
+
+
 [general.any.html]
   [Stream will not error if body is empty. It's closed with an empty queue before it errors.]
     expected: FAIL
 
   [Readable stream synchronously cancels with AbortError if aborted before reading]
     expected: FAIL
 
+
 [general.any.sharedworker.html]
   [Stream will not error if body is empty. It's closed with an empty queue before it errors.]
     expected: FAIL
 
   [Readable stream synchronously cancels with AbortError if aborted before reading]
     expected: FAIL
 
+
 [general.https.any.serviceworker.html]
   expected: TIMEOUT
 
 [general.any.serviceworker.html]
   [Readable stream synchronously cancels with AbortError if aborted before reading]
     expected: FAIL
 
   [Stream will not error if body is empty. It's closed with an empty queue before it errors.]
--- a/testing/web-platform/meta/html/browsers/the-window-object/apis-for-creating-and-navigating-browsing-contexts-by-name/open-features-tokenization-width-height.html.ini
+++ b/testing/web-platform/meta/html/browsers/the-window-object/apis-for-creating-and-navigating-browsing-contexts-by-name/open-features-tokenization-width-height.html.ini
@@ -1,24 +1,25 @@
 [open-features-tokenization-width-height.html]
   disabled:
     if webrender and not debug: bug 1425588
     if os == "android": frequently hits timeout
-
+  expected:
+    if webrender and (os == "linux"): [OK, TIMEOUT]
   ["height==402" should set height of opened window]
     expected:
-      if devedition and os == "win" and bits == 32: FAIL # bug 1540551
+      if devedition and (os == "win") and (bits == 32): FAIL
 
   ["height==402 width = 401" should set height and width of opened window]
     expected:
-      if devedition and os == "win" and bits == 32: FAIL # bug 1540551
+      if devedition and (os == "win") and (bits == 32): FAIL
 
   [",height=402,,width==401" should set height and width of opened window]
     expected:
-      if devedition and os == "win" and bits == 32: FAIL # bug 1540551
+      if devedition and (os == "win") and (bits == 32): FAIL
 
   ["\\nheight= 402" should set height of opened window]
     expected:
       if devedition and (os == "win") and (bits == 32): FAIL
 
   ["height=402" should set height of opened window]
     expected:
       if devedition and (os == "win") and (bits == 32): FAIL
@@ -45,9 +46,10 @@
 
   [" height = 402" should set height of opened window]
     expected:
       if devedition and (os == "win") and (bits == 32): FAIL
 
   ["HEIGHT=402, WIDTH=401" should set height and width of opened window]
     expected:
       if devedition and (os == "win") and (bits == 32): FAIL
+      if webrender and (os == "linux"): [PASS, TIMEOUT]
 
--- a/testing/web-platform/meta/html/browsers/windows/auxiliary-browsing-contexts/opener-setter.html.ini
+++ b/testing/web-platform/meta/html/browsers/windows/auxiliary-browsing-contexts/opener-setter.html.ini
@@ -1,11 +1,13 @@
 [opener-setter.html]
   disabled:
     if (os == "linux") and (bits == 32) and debug: https://bugzilla.mozilla.org/show_bug.cgi?id=1483696
   expected:
-    if (os == "linux") and debug and fission: ["OK", "TIMEOUT"]
-    if (os == "linux") and debug and not fission: ["OK", "TIMEOUT"]
+    if (os == "linux") and debug and fission: [OK, TIMEOUT]
+    if (os == "linux") and debug and not fission: [OK, TIMEOUT]
+    if (os == "win") and debug and not webrender and (processor == "x86_64"): [OK, TIMEOUT]
   [Auxiliary browsing context created via `window.open` and setting `window.opener` to `null` should report `window.opener` `null`]
     expected:
-      if (os == "linux") and debug and fission: ["PASS", "TIMEOUT"]
-      if (os == "linux") and debug and not fission: ["PASS", "TIMEOUT"]
+      if (os == "linux") and debug and fission: [PASS, TIMEOUT]
+      if (os == "linux") and debug and not fission: [PASS, TIMEOUT]
+      if (os == "win") and debug and not webrender and (processor == "x86_64"): [PASS, TIMEOUT]
 
--- a/testing/web-platform/meta/html/cross-origin-opener-policy/coop-sandbox.https.html.ini
+++ b/testing/web-platform/meta/html/cross-origin-opener-policy/coop-sandbox.https.html.ini
@@ -1,7 +1,9 @@
 [coop-sandbox.https.html]
   [<iframe sandbox="allow-popups allow-scripts"> Sandboxed Cross-Origin-Opener-Policy popup should result in a network error]
     expected:
-      if webrender and fission: ["PASS", "FAIL"]
-      if webrender and not fission: ["FAIL", "PASS"]
+      if webrender and fission: [PASS, FAIL]
+      if webrender and (os == "linux") and debug: [FAIL, PASS]
+      if webrender and (os == "linux") and not debug: [FAIL, PASS]
+      if webrender and (os == "win"): [FAIL, PASS]
       FAIL
 
--- a/testing/web-platform/meta/html/cross-origin-opener-policy/iframe-popup-same-origin-allow-popups-to-same-origin-allow-popups.https.html.ini
+++ b/testing/web-platform/meta/html/cross-origin-opener-policy/iframe-popup-same-origin-allow-popups-to-same-origin-allow-popups.https.html.ini
@@ -1,7 +1,12 @@
 [iframe-popup-same-origin-allow-popups-to-same-origin-allow-popups.https.html]
   expected:
-    if os == "mac": ["OK", "TIMEOUT"]
+    if os == "mac": [OK, TIMEOUT]
+    if (os == "linux") and debug and not webrender: [OK, TIMEOUT]
   [same-origin-allow-popups with SAME_SITE iframe opening popup a CROSS_ORIGIN with COOP: same-origin-allow-popups]
     expected:
-      if os == "mac": ["PASS", "TIMEOUT"]
+      if os == "mac": [PASS, TIMEOUT]
 
+  [same-origin-allow-popups with SAME_ORIGIN iframe opening popup a CROSS_ORIGIN with COOP: same-origin-allow-popups]
+    expected:
+      if (os == "linux") and debug and not webrender: [PASS, TIMEOUT]
+
new file mode 100644
--- /dev/null
+++ b/testing/web-platform/meta/html/cross-origin-opener-policy/popup-same-origin-with-same-site.https.html.ini
@@ -0,0 +1,7 @@
+[popup-same-origin-with-same-site.https.html]
+  expected:
+    if (os == "linux") and not debug and webrender: [OK, TIMEOUT]
+  [same-origin document opening popup to https://www1.web-platform.test:8443 with COOP: "same-origin-allow-popups"]
+    expected:
+      if (os == "linux") and not debug and webrender: [PASS, TIMEOUT]
+
--- a/testing/web-platform/meta/html/interaction/focus/the-autofocus-attribute/first-when-later.html.ini
+++ b/testing/web-platform/meta/html/interaction/focus/the-autofocus-attribute/first-when-later.html.ini
@@ -1,5 +1,5 @@
 [first-when-later.html]
   [The first autofocus in the document wins, even if elements are inserted later.]
     expected:
-      if (os == "android") and not debug: ["PASS", "FAIL"]
+      if (os == "android") and not debug: [PASS, FAIL]
 
--- a/testing/web-platform/meta/html/interaction/focus/the-autofocus-attribute/no-autofocus-on-changing-input-type.html.ini
+++ b/testing/web-platform/meta/html/interaction/focus/the-autofocus-attribute/no-autofocus-on-changing-input-type.html.ini
@@ -1,6 +1,6 @@
 [no-autofocus-on-changing-input-type.html]
   [Changing input type should not refocus on the element.]
     expected:
-      if not webrender and (os == "android") and not debug: ["PASS", "FAIL"]
-      if webrender: ["PASS", "FAIL"]
+      if not webrender and (os == "android") and not debug: [PASS, FAIL]
+      if webrender: [PASS, FAIL]
 
--- a/testing/web-platform/meta/html/interaction/focus/the-autofocus-attribute/queue-non-focusable.html.ini
+++ b/testing/web-platform/meta/html/interaction/focus/the-autofocus-attribute/queue-non-focusable.html.ini
@@ -1,6 +1,6 @@
 [queue-non-focusable.html]
   [If the first autofocus element is not focusable, but becomes focusable before a frame, it should be focused.]
     expected:
-      if (os == "win") and not debug and (processor == "x86_64"): ["PASS", "FAIL"]
-      if (os == "android") and not debug: ["PASS", "FAIL"]
+      if (os == "win") and not debug and (processor == "x86_64"): [PASS, FAIL]
+      if (os == "android") and not debug: [PASS, FAIL]
 
new file mode 100644
--- /dev/null
+++ b/testing/web-platform/meta/html/semantics/forms/constraints/form-validation-reportValidity.html.ini
@@ -0,0 +1,3 @@
+[form-validation-reportValidity.html]
+  expected:
+    if (os == "linux") and debug and not webrender: [OK, CRASH]
--- a/testing/web-platform/meta/inert/inert-retargeting-iframe.tentative.html.ini
+++ b/testing/web-platform/meta/inert/inert-retargeting-iframe.tentative.html.ini
@@ -2,15 +2,15 @@
   expected: ERROR
   [Tests that any mouse event on an inert element is targeted to the nearest non-inert ancestor at the same coordinates]
     expected: FAIL
 
   [Tests that any mouse event on a non-inert element is correctly targeted to that element]
     disabled:
       if webrender and debug and (os == "linux"): wpt-sync Bug 1564668
     expected:
-      if not debug and not fission and webrender and (os == "linux"): ["PASS", "FAIL"]
-      if not debug and fission and (os == "linux"): ["PASS", "FAIL"]
-      if debug and (os == "win"): ["PASS", "FAIL"]
+      if not debug and not fission and webrender and (os == "linux"): [FAIL, PASS]
+      if not debug and fission and (os == "linux"): [PASS, FAIL]
+      if debug and (os == "win"): [PASS, FAIL]
 
   [Tests that any pointer event on an inert element is targeted to the nearest non-inert ancestor at the same coordinates]
     expected: FAIL
 
--- a/testing/web-platform/meta/mediacapture-streams/historical.https.html.ini
+++ b/testing/web-platform/meta/mediacapture-streams/historical.https.html.ini
@@ -1,4 +1,6 @@
 [historical.https.html]
+  expected:
+    if (processor == "x86") and not debug: [OK, TIMEOUT]
   [navigator.mozGetUserMedia should not exist]
     expected: FAIL
 
--- a/testing/web-platform/meta/referrer-policy/css-integration/svg/processing-instruction.html.ini
+++ b/testing/web-platform/meta/referrer-policy/css-integration/svg/processing-instruction.html.ini
@@ -1,5 +1,5 @@
 [processing-instruction.html]
   [Styling SVG from ProcessingInstruction fill]
     expected:
-      if webrender and (os == "linux") and not debug and not fission: ["PASS", "FAIL"]
+      if webrender and (os == "linux") and not debug and not fission: [PASS, FAIL]
 
--- a/testing/web-platform/meta/resource-timing/resource-timing-level1.sub.html.ini
+++ b/testing/web-platform/meta/resource-timing/resource-timing-level1.sub.html.ini
@@ -1,108 +1,132 @@
 [resource-timing-level1.sub.html]
   disabled:
     if os == "mac": https://bugzilla.mozilla.org/show_bug.cgi?id=1543604
     if os == "android": https://bugzilla.mozilla.org/show_bug.cgi?id=1543604
   ['link responseStart uses 1XX (first) response timings']
     expected:
-      if (processor == "x86") and debug: ["PASS", "FAIL"]
-      if (processor == "x86") and not debug: ["PASS", "FAIL"]
+      if (processor == "x86") and debug: [PASS, FAIL]
+      if (processor == "x86") and not debug: [PASS, FAIL]
+      if (processor == "x86_64") and (os == "win") and not debug and webrender: [PASS, FAIL]
 
   ['script responseStart uses 1XX (first) response timings']
     expected:
-      if (processor == "x86") and debug: ["PASS", "FAIL"]
-      if (processor == "x86") and not debug: ["PASS", "FAIL"]
+      if (processor == "x86") and debug: [PASS, FAIL]
+      if (processor == "x86") and not debug: [PASS, FAIL]
+      if (processor == "x86_64") and (os == "win") and not debug and webrender: [PASS, FAIL]
 
   ['iframe responseStart uses 1XX (first) response timings']
     expected:
-      if (processor == "x86") and not debug: ["PASS", "FAIL"]
-      if (processor == "x86") and debug: ["PASS", "FAIL"]
+      if (processor == "x86") and not debug: [PASS, FAIL]
+      if (processor == "x86") and debug: [PASS, FAIL]
+      if (processor == "x86_64") and (os == "win") and not debug and webrender: [PASS, FAIL]
 
   ['xmlhttprequest responseStart uses 1XX (first) response timings']
     expected:
-      if (processor == "x86") and debug: ["PASS", "FAIL"]
-      if (processor == "x86") and not debug: ["PASS", "FAIL"]
+      if (processor == "x86") and debug: [PASS, FAIL]
+      if (processor == "x86") and not debug: [PASS, FAIL]
+      if (processor == "x86_64") and (os == "win") and not debug and webrender: [PASS, FAIL]
 
   ['xmlhttprequest (Potentially Cached): Immediately fetch the same URL, exercising the cache hit path (if any).]
     expected:
-      if (processor == "x86") and debug: ["PASS", "FAIL"]
+      if (processor == "x86") and debug: [PASS, FAIL]
+      if (processor == "x86_64") and (os == "win") and not debug and webrender: [PASS, FAIL]
 
   ['link 250ms delay in headers does not affect responseStart']
     expected:
-      if (processor == "x86") and debug: ["PASS", "FAIL"]
-      if (processor == "x86") and not debug: ["PASS", "FAIL"]
+      if (processor == "x86") and debug: [PASS, FAIL]
+      if (processor == "x86") and not debug: [PASS, FAIL]
+      if (processor == "x86_64") and (os == "win") and not debug and webrender: [PASS, FAIL]
 
   ['iframe 250ms delay in headers does not affect responseStart']
     expected:
-      if (processor == "x86") and debug: ["PASS", "FAIL"]
-      if (processor == "x86") and not debug: ["PASS", "FAIL"]
+      if (processor == "x86") and debug: [PASS, FAIL]
+      if (processor == "x86") and not debug: [PASS, FAIL]
+      if (processor == "x86_64") and (os == "win") and not debug and webrender: [PASS, FAIL]
 
   ['xmlhttprequest: 250ms delay before 'responseStart', another 250ms delay before 'responseEnd'.]
     expected:
-      if (processor == "x86") and debug: ["PASS", "FAIL"]
+      if (processor == "x86") and debug: [PASS, FAIL]
+      if (processor == "x86_64") and (os == "win") and not debug and webrender: [PASS, FAIL]
 
   ['xmlhttprequest (Redirected): 250ms delay before 'redirectEnd', another 250ms delay before 'responseStart'.]
     expected:
-      if (processor == "x86") and debug: ["PASS", "FAIL"]
+      if (processor == "x86") and debug: [PASS, FAIL]
+      if (processor == "x86_64") and (os == "win") and not debug and webrender: [PASS, FAIL]
 
   ['iframe (Populate cache): The initial request populates the cache (if appropriate).]
     expected:
-      if (processor == "x86") and debug: ["PASS", "FAIL"]
+      if (processor == "x86") and debug: [PASS, FAIL]
+      if (processor == "x86_64") and (os == "win") and not debug and webrender: [PASS, FAIL]
 
   ['script: 250ms delay before 'responseStart', another 250ms delay before 'responseEnd'.]
     expected:
-      if (processor == "x86") and debug: ["PASS", "FAIL"]
+      if (processor == "x86") and debug: [PASS, FAIL]
+      if (processor == "x86_64") and (os == "win") and not debug and webrender: [PASS, FAIL]
 
   ['link (Potentially Cached): Immediately fetch the same URL, exercising the cache hit path (if any).]
     expected:
-      if (processor == "x86") and debug: ["PASS", "FAIL"]
+      if (processor == "x86") and debug: [PASS, FAIL]
+      if (processor == "x86_64") and (os == "win") and not debug and webrender: [PASS, FAIL]
 
   ['xmlhttprequest 250ms delay in headers does not affect responseStart']
     expected:
-      if (processor == "x86") and not debug: ["PASS", "FAIL"]
-      if (processor == "x86") and debug: ["PASS", "FAIL"]
+      if (processor == "x86") and not debug: [PASS, FAIL]
+      if (processor == "x86") and debug: [PASS, FAIL]
+      if (processor == "x86_64") and (os == "win") and not debug and webrender: [PASS, FAIL]
 
   ['link (Redirected): 250ms delay before 'redirectEnd', another 250ms delay before 'responseStart'.]
     expected:
-      if (processor == "x86") and debug: ["PASS", "FAIL"]
+      if (processor == "x86") and debug: [PASS, FAIL]
+      if (processor == "x86_64") and (os == "win") and not debug and webrender: [PASS, FAIL]
 
   ['script (Potentially Cached): Immediately fetch the same URL, exercising the cache hit path (if any).]
     expected:
-      if (processor == "x86") and debug: ["PASS", "FAIL"]
+      if (processor == "x86") and debug: [PASS, FAIL]
+      if (processor == "x86_64") and (os == "win") and not debug and webrender: [PASS, FAIL]
 
   ['script (Redirected): 250ms delay before 'redirectEnd', another 250ms delay before 'responseStart'.]
     expected:
-      if (processor == "x86") and debug: ["PASS", "FAIL"]
+      if (processor == "x86") and debug: [PASS, FAIL]
+      if (processor == "x86_64") and (os == "win") and not debug and webrender: [PASS, FAIL]
 
   ['script (Populate cache): The initial request populates the cache (if appropriate).]
     expected:
-      if (processor == "x86") and debug: ["PASS", "FAIL"]
+      if (processor == "x86") and debug: [PASS, FAIL]
+      if (processor == "x86_64") and (os == "win") and not debug and webrender: [PASS, FAIL]
 
   ['script 250ms delay in headers does not affect responseStart']
     expected:
-      if (processor == "x86") and not debug: ["PASS", "FAIL"]
-      if (processor == "x86") and debug: ["PASS", "FAIL"]
+      if (processor == "x86") and not debug: [PASS, FAIL]
+      if (processor == "x86") and debug: [PASS, FAIL]
+      if (processor == "x86_64") and (os == "win") and not debug and webrender: [PASS, FAIL]
 
   ['xmlhttprequest (Populate cache): The initial request populates the cache (if appropriate).]
     expected:
-      if (processor == "x86") and debug: ["PASS", "FAIL"]
+      if (processor == "x86") and debug: [PASS, FAIL]
+      if (processor == "x86_64") and (os == "win") and not debug and webrender: [PASS, FAIL]
 
   ['iframe (Potentially Cached): Immediately fetch the same URL, exercising the cache hit path (if any).]
     expected:
-      if (processor == "x86") and debug: ["PASS", "FAIL"]
+      if (processor == "x86") and debug: [PASS, FAIL]
+      if (processor == "x86_64") and (os == "win") and not debug and webrender: [PASS, FAIL]
 
   ['link: 250ms delay before 'responseStart', another 250ms delay before 'responseEnd'.]
     expected:
-      if (processor == "x86") and debug: ["PASS", "FAIL"]
+      if (processor == "x86") and debug: [PASS, FAIL]
+      if (processor == "x86_64") and (os == "win") and not debug and webrender: [PASS, FAIL]
 
   ['iframe (Redirected): 250ms delay before 'redirectEnd', another 250ms delay before 'responseStart'.]
     expected:
-      if (processor == "x86") and debug: ["PASS", "FAIL"]
+      if (processor == "x86") and debug: [PASS, FAIL]
+      if (processor == "x86_64") and (os == "win") and not debug and webrender: [PASS, FAIL]
 
   ['link (Populate cache): The initial request populates the cache (if appropriate).]
     expected:
-      if (processor == "x86") and debug: ["PASS", "FAIL"]
+      if (processor == "x86") and debug: [PASS, FAIL]
+      if (processor == "x86_64") and (os == "win") and not debug and webrender: [PASS, FAIL]
 
   ['iframe: 250ms delay before 'responseStart', another 250ms delay before 'responseEnd'.]
     expected:
-      if (processor == "x86") and debug: ["PASS", "FAIL"]
+      if (processor == "x86") and debug: [PASS, FAIL]
+      if (processor == "x86_64") and (os == "win") and not debug and webrender: [PASS, FAIL]
 
--- a/testing/web-platform/meta/svg/text/reftests/dominant-baseline-hanging-small-font-size.svg.ini
+++ b/testing/web-platform/meta/svg/text/reftests/dominant-baseline-hanging-small-font-size.svg.ini
@@ -1,4 +1,4 @@
 [dominant-baseline-hanging-small-font-size.svg]
   expected:
-    if (processor == "x86") and debug: ["PASS", "FAIL"]
-    if (processor == "x86") and not debug: ["PASS", "FAIL"]
+    if (processor == "x86") and debug: [PASS, FAIL]
+    if (processor == "x86") and not debug: [PASS, FAIL]
new file mode 100644
--- /dev/null
+++ b/testing/web-platform/meta/webaudio/the-audio-api/the-convolvernode-interface/convolution-mono-mono.html.ini
@@ -0,0 +1,4 @@
+[convolution-mono-mono.html]
+  expected:
+    if (os == "win") and not debug and (processor == "x86_64") and not webrender: [OK, TIMEOUT]
+    if (os == "win") and not debug and (processor == "x86_64") and webrender: [OK, TIMEOUT]
new file mode 100644
--- /dev/null
+++ b/testing/web-platform/meta/webaudio/the-audio-api/the-convolvernode-interface/convolver-upmixing-1-channel-response.html.ini
@@ -0,0 +1,3 @@
+[convolver-upmixing-1-channel-response.html]
+  expected:
+    if webrender and (os == "win") and not debug: [OK, TIMEOUT]
new file mode 100644
--- /dev/null
+++ b/testing/web-platform/meta/webrtc/RTCDTMFSender-ontonechange-long.https.html.ini
@@ -0,0 +1,7 @@
+[RTCDTMFSender-ontonechange-long.https.html]
+  expected:
+    if (os == "linux") and not debug and not webrender: [OK, TIMEOUT]
+  [insertDTMF with duration greater than 6000 should be clamped to 6000]
+    expected:
+      if (os == "win") and not debug and not webrender and (processor == "x86_64"): [PASS, FAIL]
+
--- a/testing/web-platform/meta/webrtc/RTCPeerConnection-createDataChannel.html.ini
+++ b/testing/web-platform/meta/webrtc/RTCPeerConnection-createDataChannel.html.ini
@@ -1,16 +1,16 @@
 [RTCPeerConnection-createDataChannel.html]
   expected:
-    if processor == "aarch64": ["OK", "TIMEOUT"]
-
+    if processor == "aarch64": [OK, TIMEOUT]
+    if (processor == "x86") and not debug: [OK, CRASH]
   [addTrack, then createDataChannel, should negotiate properly]
     expected:
-      if processor == "aarch64": ["PASS", "TIMEOUT"]
+      if processor == "aarch64": [PASS, TIMEOUT]
 
   [Stopping the bundle-tag when there is a DataChannel in the bundle should kill the DataChannel]
     expected:
-      if processor == "aarch64": ["PASS", "NOTRUN"]
+      if processor == "aarch64": [PASS, NOTRUN]
 
   [addTrack, then createDataChannel, should negotiate properly when max-bundle is used]
     expected:
-      if processor == "aarch64": ["PASS", "NOTRUN"]
+      if processor == "aarch64": [PASS, NOTRUN]
 
--- a/testing/web-platform/meta/webrtc/RTCPeerConnection-ondatachannel.html.ini
+++ b/testing/web-platform/meta/webrtc/RTCPeerConnection-ondatachannel.html.ini
@@ -6,21 +6,19 @@
 
   [In-band negotiated channel created on remote peer should match the same configuration as local peer]
     bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1551589, https://bugzilla.mozilla.org/show_bug.cgi?id=1613433
     expected: [FAIL, NOTRUN]
 
   [Open event should not be raised when sending and immediately closing the channel in the datachannel event]
     bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1613433
     expected:
-      if (os == "linux") and not webrender and not debug: ["PASS", "NOTRUN", "TIMEOUT"]
+      if (os == "linux") and not webrender and not debug: [PASS, TIMEOUT, NOTRUN]
       [PASS, TIMEOUT]
 
   [Negotiated channel should not fire datachannel event on remote peer]
     bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1613433
-    expected:
-      if (os == "linux") and not webrender and not debug: ["PASS", "NOTRUN", "TIMEOUT"]
-      [PASS, TIMEOUT, NOTRUN]
+    expected: [PASS, TIMEOUT, NOTRUN]
 
   [Open event should be raised when closing the channel in the datachannel event after enqueuing a task]
     expected:
-      if (os == "linux") and not webrender and not debug: ["PASS", "TIMEOUT"]
+      if (os == "linux") and not webrender and not debug: [PASS, TIMEOUT]
 
--- a/testing/web-platform/meta/webrtc/RTCPeerConnection-operations.https.html.ini
+++ b/testing/web-platform/meta/webrtc/RTCPeerConnection-operations.https.html.ini
@@ -1,4 +1,7 @@
 [RTCPeerConnection-operations.https.html]
+  expected:
+    if (os == "win") and not debug and not webrender and (processor == "x86_64"): [OK, TIMEOUT]
   [sender.getStats does NOT use the operations chain]
     bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1620689
     expected: FAIL
+
--- a/testing/web-platform/meta/webrtc/RTCPeerConnection-setRemoteDescription-offer.html.ini
+++ b/testing/web-platform/meta/webrtc/RTCPeerConnection-setRemoteDescription-offer.html.ini
@@ -1,8 +1,15 @@
 [RTCPeerConnection-setRemoteDescription-offer.html]
   [setRemoteDescription(offer) with invalid SDP should reject with RTCError]
+    bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1527916
     expected: FAIL
-    bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1527916
 
   [setRemoteDescription(invalidOffer) from have-local-offer does not undo rollback]
+    bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1527916
     expected: FAIL
-    bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1527916
+
+  [repeated sRD(offer) works]
+    expected:
+      if debug and (processor == "x86"): FAIL
+      if not debug and (os == "linux"): FAIL
+      if not debug and (os == "win"): FAIL
+
--- a/testing/web-platform/meta/webrtc/RTCRtpReceiver-getStats.https.html.ini
+++ b/testing/web-platform/meta/webrtc/RTCRtpReceiver-getStats.https.html.ini
@@ -1,9 +1,11 @@
 [RTCRtpReceiver-getStats.https.html]
+  expected:
+    if (os == "linux") and not debug and webrender: [OK, TIMEOUT]
   [receiver.getStats() via addTransceiver should return stats report containing inbound-rtp stats]
     bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1225720
     expected: FAIL
 
   [receiver.getStats() via addTrack should return stats report containing inbound-rtp stats]
     bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1225720
     expected: FAIL